Apple TV Rentals/Setup Question

Discussion in 'Apple TV and Home Theater' started by butterwm, Sep 27, 2013.

  1. macrumors member

    #1
    We have three Apple TV's in our house. We use the same iTunes account for all three Apple TV's. We are having an issue when we rent movies. We will rent a movie and I understand they are good for 24 hours once you start watching them. We start a movie at night and want to finish it in the morning. The next morning, the movie is no longer there to watch and the only option is to rent it again.

    However, one one of my Apple TV's the rental shows up but not on the other two. The AppleTV that it shows up on is not even the same one we rented the movie on.

    Is there possibly a setting I am missing that would cause this problem?
     
  2. macrumors 6502a

    #2
    http://support.apple.com/kb/HT1415

    I think this the applicable point here.

    " If you rent a movie on an iPhone, iPad, iPod touch, or Apple TV, it is not transferable to any other device and you must watch it on that device."
     
  3. macrumors member

    #3
    The problem is that it's not even showing up on that same device. We tried to watch it on the same AppleTV that we rented it and watched the first half on.

    In the past, since we use the same iTunes account on all three Apple TV's, if we rented a movie it would show up on all three devices and we could watch it on anyone.
     
  4. macrumors 6502a

    #4
    In the past, did you rent it in iTunes on computer rather than ATV? According to the above article, you get more viewing options that way.

    http://forums.macrumors.com/showthread.php?p=17985912#post17985912

    In this thread another poster claims he was able to re-view the rental by clicking rent again. Within the 24 hr. limit of course.
     
  5. macrumors member

    #5
    The one thing we didn't do was try clicking on the rent button. I was afraid they would charge me a second time for the same movie. I will try that next time to see if it works.

    Thanks for your help!
     
  6. macrumors newbie

    #6
    Rental Bug in Apple TV

    Don't rent it again! I was close to doing that as well, just this morning.

    Instead, I called Apple Support and got the issue resolved.

    IT'S A BUG in Apple TV, and let's hope an update soon fixes it.

    Background: We rented World War Z from our Apple TV last night. Fine and good. Today, we wanted to see it again. It was not to be found. I went to Settings, iTunes Store, Check Rentals, and all I got was the rotating spoke wheel. Tried a number of things, nothing worked. Finally called Apple Support.

    Here's what will fix the issue. On your Apple TV, sign out of iTunes. Then unplug the power to your Apple TV. Plug it back in after a few seconds. Sign back into iTunes. You will see your rental.

    The rental period is set to be 48 hours on the Apple TV, not 24. I know it is listed as 24 hours elsewhere (I think I saw that on the computer on iTunes), but the 48 figure is correct. When I went to play the rental early this afternoon it said we had 31 hours (or so) left.

    I hope Apple gets its house in order. These things should not be happening.
    It's just supposed to work!

    Mark

    ----------

    I shouldn't have said don't rent it again. Maybe it would indeed have allowed you to see the rental again at no extra charge, within the 48 hour window. I just didn't go that route because I figured the worst.

    Mark
     

Share This Page