Apple TV Update buggy?

Discussion in 'Apple TV and Home Theater' started by KeepCalmPeople, Feb 25, 2013.

  1. macrumors 65816

    KeepCalmPeople

    Joined:
    Sep 5, 2012
    Location:
    San Francisco Bay Area, California
    #1
    I was informed that an update was available for my 2 Apple TVs last night, so I installed both updates. This evening I'm watching Netflix and I get a connection error message. This is not terribly unusual, so I click on the menu/back button on the remote. This takes me back to Episodes screen for the TV show I'm watching ('Psych'), but I can STILL see the connection error message behind the episodes list. Even putting the Apple TV to sleep and then awakening it doesn't remove the message.

    Weird. My Apple TVs have performed flawlessly since I bought them months ago, aside from Internet connectivity issues caused by my router and my ISP.
     
  2. macrumors 68000

    Joined:
    Mar 30, 2011
    Location:
    NY USA
    #2
    I have had all sorts of odd things happen since the last update but the one I notice the most is the Apple TV is sooooo slooooooow now. Slow to turn on and show the menu, slow to load an app, just slooooooow.

    Also, on occasion I have no sound, or the sound, such as selecting or moving around icons will start 20 to 30 seconds after the menu shows.

    I hope, hope HOPE Apple didn't do this on purpose to get people to buy the revised Apple TV to offer higher performance....I doubt they did, but something isn't right. It should not take 5 to 10 seconds to show the menu from sleep mode.
     
  3. macrumors newbie

    Joined:
    Feb 7, 2012
    #3
    Ugh! Mine keeps going back to the home screen after about 5 minutes unless I'm streaming something.

    Otherwise, even if I'm using the Radio or just pausing Netflix to get a snack, the stupid thing will go back to the home screen after a quick delay with the "loading" icon.

    About to reset to factory but thought I might find something here. ATV2.
     
  4. macrumors member

    Joined:
    Jul 27, 2012
    #4
    Always completely unplug your ATV after an update. Wait a minute or so and then plug back in. This seems to clear its memory, cache, whatever, and everything will work fine.
     
  5. macrumors 6502a

    Joined:
    Sep 16, 2010
    Location:
    Melbourne, Australia
    #5
    I can't even install the latest update. Tried on two separate atv3s and it goes through the motions, then comes up with the message, Failed to install latest update.

    Then everyday, I get the message....there's an update available with the install/do not install options presented. Most annoying.
     
  6. macrumors regular

    machpost

    Joined:
    Jan 28, 2010
    #6
    I don't know if it's connected to the most recent update, but if I pause a program that I'm playing via Airplay, and I let enough time go by till the screen saver kicks in (two minutes in my case), it will make the Apple TV re-boot.
     
  7. macrumors 6502a

    Joined:
    Jun 29, 2009
    Location:
    Australia
    #7
    Same here, 2 of the 3 wont install, the 3rd did install OK
     
  8. macrumors newbie

    Joined:
    Feb 7, 2012
    #8
    Thanks for the tip, I'll give that a shot.
     
  9. macrumors newbie

    Joined:
    Feb 7, 2012
    #9
    Update: Unplugging did not help my issue. I'll just take it in to the local Apple store and see if they have anything to say.
     
  10. macrumors member

    Joined:
    Jan 13, 2012
    #10
    I got the update waiting message lately and finally got around to doing the update. It took over 2 hours for the update to prepare (download?). It was extremely slow. My internet connection is reasonably fast (30 mbps) and it was running fine during this time so it was either the Apple TV itself that was slow or the Apple servers. In any case, I hope it never happens again. That is just unacceptable for an update.
     

Share This Page