Apple TV won't load libraries over Airplay

Discussion in 'Apple TV and Home Theater' started by JoshMKB24, Sep 17, 2013.

  1. macrumors 6502


    Ok when I click on "computers" on the Apple TV home screen I see both my desktop and laptop libraries in there. However when I click on them, it says libraries are empty. I checked both comps to make sure home sharing was on and it was. I also unplugged and replugged it in to see if that worked. Also tried a different tv........same thing. I checked to see if maybe I was needing a software update but that was up to date along with my current router settings. I searched this board and couldn't find anything. The only thing I can think of is I switched to the new Airport Extreme recently, but I believe I have listened to music over my ATV since then, but can't be sure.......however I don't see how that would be causing a problem, especially when my ATV sees the libraries just says they are empty. Thanks!
  2. macrumors newbie

    Basic Troubleshooting

    I have had this happen in the past and one the below basic steps usually fixed the issue:

    - Make sure iTunes (on computers) and AppleTV is updated
    - Reboot computers

    Also see if you can see each iTunes library between you laptop and CPU (test playing a movie/show from CPU to Laptop or vise versa), this will show if it the AppleTV or iTunes itself.

    Hopefully this makes your AppleTV "just work" --- Sorry I could not be more help but no one else responded so I thought I would toss out some ideas.
  3. macrumors 6502


    Thanks, I did make sure all software was updated on all devices and did reboot the computers. There was even a update to OSX recently that rebooted them again as well. I will try playing something out of the library this evening when I get home from 1 computer to the other and see if that works.

    Thanks for the ideas, every idea I haven't tried is worth giving a shot!
  4. macrumors 68020

    that's not airplay, that's home sharing.

    airplay is sitting at your computer, then in iTunes selecting music to play, and then selecting the output for that music. or playing something from your iOS device to the aTV.
    for airplay the aTV is a "dumb receiver" that does nothing but play what is sent to it.

    Try turning home sharing off and on, on both your macs and the aTV.
    make sure they are all logged on to the same home sharing account.
    go into iTunes preferences, try turning off the password on sharing if there is one.
  5. macrumors 6502


    Thanks for the heads up. That seemed to fix it.

    This Apple TV thing is a fickle device it seems. I was having trouble with the speed of streaming and a simple unplugging and plugging it back in seemed to correct it. Then this whole thing and just turning home sharing off and on seems to fix it. Or maybe I'm just doing something wrong?

Share This Page