Appletalk Problems (Printing)

Discussion in 'macOS' started by TEG, Dec 9, 2005.

  1. TEG macrumors 604

    TEG

    Joined:
    Jan 21, 2002
    Location:
    Langley, Washington
    #1
    I'm trying to my PowerBook to print to an HP LaserJet 5000N. It worked for a while using AppleTalk, but then after upgrading to 10.4.3 I get an error that AppleTalk is not on when I try to print. However, AppleTalk is turned on, on my ethernet connection, and it is all configured correctly on the printer. I've tried restarting; turning off AppleTalk, then restarting, and reactivating AppleTalk; nothing seems to help.

    Please Help, my computer is the only one that can print 11x17 correctly on this printer (The XP machines can't for some reason.)

    TEG
     
  2. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #2
    How is the PowerBook connected to the printer? I gather there's an ethernet connection involved, is it a direct cable from the PowerBook to another Mac with the printer attached? :)
     
  3. CanadaRAM macrumors G5

    CanadaRAM

    Joined:
    Oct 11, 2004
    Location:
    On the Left Coast - Victoria BC Canada
    #3
    If the connetion is over a non-Apple wireless router, Appletalk is most likely not being passed through the wireless connection. (Wired should be Ok)

    Can the HP support IP printing? What happens if you look up the HP's IP address (you should be able tp get it to print its configuration page from the front panel manuals) and set it up in Printer Setup as an IP printer.

    Be a good thig to check too if some bright spark turned Appletalk off on the printer, too.
     
  4. TEG thread starter macrumors 604

    TEG

    Joined:
    Jan 21, 2002
    Location:
    Langley, Washington
    #4
    I've tried both direct connection and via hub. IP printing doesn't work, nor does printing via the print server that was setup.

    Connected Via Plain CAT5 Ethernet. The odd thing is the error in OSX that says AppleTalk is not active, although it clearly is. I'm half convinced that 10.4.3 broke AppleTalk.

    TEG
     
  5. nykansukee macrumors newbie

    Joined:
    Dec 8, 2005
    Location:
    NY
  6. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #6
    It isn't, not legally anyway.
     
  7. TEG thread starter macrumors 604

    TEG

    Joined:
    Jan 21, 2002
    Location:
    Langley, Washington
    #7
    Its 10.4.3. I've been so busy the last few weeks, I haven't paid attention.

    TEG
     
  8. IJ Reilly macrumors P6

    IJ Reilly

    Joined:
    Jul 16, 2002
    Location:
    Palookaville
    #8
    No, it hasn't. I still run my old AppleTalk LaserJet 5MP as a networked printer in 10.4.3. Are you using an AppleTalk/Ethernet bridge, such as a Farallon Ethermac?
     
  9. TEG thread starter macrumors 604

    TEG

    Joined:
    Jan 21, 2002
    Location:
    Langley, Washington
    #9
    I'm using Ethernet, connecting to the HP JetDrect Port on the back of the printer. It does not matter what cable I use, or if I connect directly, or via the local network. It only started after 10.4.3 came out, that it why I assumed it at being the culprit.

    TEG
     
  10. IJ Reilly macrumors P6

    IJ Reilly

    Joined:
    Jul 16, 2002
    Location:
    Palookaville
    #10
    I don't think you even need AppleTalk turned on if you use a JetDirect print server. I can't explain why the problem just cropped up, but I suspect a network issue of some kind. I'd go through the printer setup process again. How do you configure the JetDirect?
     
  11. TEG thread starter macrumors 604

    TEG

    Joined:
    Jan 21, 2002
    Location:
    Langley, Washington
    #11
    I'm using Ethertalk on the JetDirect Server (i.e. Appletalk). I do it this way, because as a student I can't get an address on the network. This is in an office where I do a lot of work at school (as Editor of the Newspaper) and mine seems to be the only system able to print in 11x17.

    I have tried resetting the printer to defaults, but that has not helped either.

    TEG
     

Share This Page