AppleTV 2 Unable to Stream Anything from MBP running Lion 10.7.2

Discussion in 'Apple TV and Home Theater' started by Bending Pixels, Jan 3, 2012.

  1. macrumors 6502a

    Joined:
    Jul 22, 2010
    #1
    My setup - Spring 2010 MBP (base model with 8gigs of RAM) running Lion 10.7.2, Apple Airport Extreme router, and Apple TV 2 (latest update applied). Firewall is on, on the MBP.

    AppleTV 2 sees my computer in the list of available computers (my wife's laptop running Win7 and iTunes 10.5 also appears). When I try and access my library, ATV2 spends about a minute searching, and then gives a message that it's unable to access my library. No problems accessing my wife's iTunes library.

    As a check, I have an external HD loaded with Snow Leopard. I switched to that drive, and ATV2 can access and play the contents without any problem.

    Thoughts/suggestions?

    As a side note, when iTunes went from v. 9 to v. 10 on Snow Leopard, in order to get it to work properly, I had to uninstall iTunes 9 and manually install v. 10. would doing this for the latest version possibily fix the issue?

    Thanx!
     
  2. macrumors 65816

    Joined:
    Mar 13, 2007
    Location:
    Houston, TX
    #2
    Is your MBP awake with iTunes open and running when you try to connect to it? Do you have wake on network turned on?

    Depending on your model of MBP it may not be able to wake on network, but you should look for the option in Settings. If you don't have that option, you're going to have to leave the CPU running. Either way, iTunes has to be open in order for the ATV to access your iTunes content.
     
  3. macrumors 65816

    Joined:
    Jul 7, 2011
    #3
    And make sure that when iTunes is open it's using the correct library profile.

    E.g. make sure iTunes has fully quit/closed. Then open it holding down the option key. Choose your library profile that corresponds to the data that hasn't been found.
     
  4. thread starter macrumors 6502a

    Joined:
    Jul 22, 2010
    #4
    Yep...it's awake when I've tried streaming.

    Here's the weird thing - when running under Snow Leopard (same configuration, etc.) there aren't any problems. But with Lion...nada.
     
  5. macrumors 65816

    Joined:
    Jul 7, 2011
    #5
    Are you sure you have home sharing turned on in your iTunes profile/library that won't work. It's enabled on a profile basis not a program basis afaik.
     
  6. thread starter macrumors 6502a

    Joined:
    Jul 22, 2010
  7. macrumors newbie

    Joined:
    Jan 4, 2012
    #7
    I have just come across this exact same problem on a clients MacBook Air

    Same version 10.7.2, all updates installed, no firewall enabled. I can airplay perfectly fine from other iPad2, iPod and Windows/iTunes devices on the same wireless SSID, just not from the MBA.

    I'll check back for updates and post an update if I make any progress on this issue myself

    KP
     
  8. macrumors newbie

    sford56

    Joined:
    Aug 11, 2011
    Location:
    Mexico City
    #8
    After searching forever for a solution to this, I have finally found the culprit on my 2011 mini server. I followed the instructions here:
    From this thread:
    https://discussions.apple.com/thread/3535170?start=0&tstart=0

    This disables the port blocking that is apparently inherent to Lion Server. I'm not sure if this applies to non server models (my Wife's '08 MBP did not have the issue on Lion), but it worked for me. Please note, this disables a section of your ipv6 firewall (which runs whether or not you have the firewall "enabled" in prefs), so use at your own risk (I'm behind a router firewall on my home network)

    Hope this helps.
     

Share This Page