Application submission and 57x57px image

Discussion in 'iOS Programming' started by RossOliver, Aug 28, 2008.

  1. macrumors regular

    Joined:
    Nov 6, 2006
    #1
    Hey,

    When you upload an application bundle for review, do you include the 57x57px image in the root of the zip file, or does it automatically get it from the .app bundle?

    Cheers,

    -Ross
     
  2. macrumors 68000

    Joined:
    Nov 3, 2007
    #2
    It pulls it from the .app bundle.
     
  3. thread starter macrumors regular

    Joined:
    Nov 6, 2006
    #3
    Thought as much, but I wondered if that was why my app was rejected as 'corrupt'...

    Cheers
     
  4. macrumors 68000

    Joined:
    Nov 3, 2007
    #4
    I had an app rejected as corrupt, I just rebuilt and resubmitted it, it then went through fine.
     
  5. thread starter macrumors regular

    Joined:
    Nov 6, 2006
    #5
    I'm having issues re-submitting mine :( the link to re-upload that appears next to 'waiting for upload' disappeared for some reason and it wont go through with the application loader so now it's just stuck on 'waiting for upload'...

    Out of interest, how long did your review take after re-submission? I'll not be happy if they shunt me to the back fo the queue again :rolleyes:

    -Ross
     
  6. macrumors 68000

    Joined:
    Nov 3, 2007
    #6
    Took about 3 days to get the re-sub into the store. So it seems like you get thrown into the middle of the queue. As for you app loader problem, I do all my uploading direct through ITC.
     
  7. thread starter macrumors regular

    Joined:
    Nov 6, 2006
    #7

    When you re-uploaded your app did you use a link next to the 'In Review' message (or it may have been something else at the time) or is there another place on ITC to upload that I'm missing?

    -Ross
     
  8. macrumors 68000

    Joined:
    Nov 3, 2007
    #8
    I reuploaded by clicking the button next to where it said 'Rejected' I believe the button said 'Replace Binary'
     
  9. thread starter macrumors regular

    Joined:
    Nov 6, 2006
    #9
    Ah, yea that's what I had but it seems to disappear when you click it so I can't get back there now... very frustrating!

    -Ross
     

Share This Page