Applications not opening after running software updater - Any help appreciated!

Discussion in 'macOS' started by ManRaySky, Jan 29, 2007.

  1. ManRaySky macrumors newbie

    Joined:
    Jan 29, 2007
    Location:
    London, UK
    #1
    Hi

    Sorry that my first post on the forum is a cry for help, but my ibook G4 does not work after running the OS X update from the Software updater. All installed fine but now if I try and open Safari, Mail or any utility programs I get an unexpectedly quit error message. :(

    Any help on how to get everything working again would be great (can I roll back the update? Or have to reinstall from scratch?)

    Thanks
     
  2. adrianblaine macrumors 65816

    adrianblaine

    Joined:
    Oct 12, 2006
    Location:
    Pasadena, CA
    #2
    Welcome and sorry you are having trouble.

    Which OS are you using? have you rebooted yet? I've never heard of this problem before.
     
  3. ManRaySky thread starter macrumors newbie

    Joined:
    Jan 29, 2007
    Location:
    London, UK
    #3
    Hi

    thanks for your reply.

    I'm running OS X, and just ran the software updater with the latest upgrade for OS - I have to admit that I haven't run it for about 6 months. I've rebooted a few times, but the errors keep appearing.
     
  4. islandmonusvi macrumors newbie

    islandmonusvi

    Joined:
    Nov 29, 2006
    Location:
    U.S. Virgin Islands
    #4
    This sure looks like a Permission issue.
    Are you using the correct Boot Log-In with 'Admin' privileges ?
    Insert your Install CD ..holding down the "C" key. Then use Disk Utility to verify & repair Permissions.
    or use Terminal
    "sudo diskutil repairpermissions " ( no quotes ) then at prompt > Password:
    type in your password and hit > enter
     
  5. ManRaySky thread starter macrumors newbie

    Joined:
    Jan 29, 2007
    Location:
    London, UK
    #5
    Many thanks, I'll give that a try tonight. If that doesn't work would an archive an install be the best bet?

    cheers.
     
  6. ManRaySky thread starter macrumors newbie

    Joined:
    Jan 29, 2007
    Location:
    London, UK
    #6
    Hi

    I tried using Terminal, and it seemed to repair permissions, however the applications still won't open. - Also it asked for the drive to repair permissions on so am I typing it correctly. I wrote

    sodu diskutil repairpermissions / "name of owner"

    I also tried to insert the install disk I got with the laptop and it keeps rejecting it. It thinks about reading it for about 10 seconds and then spits it out !

    Any further help would be much appreciated. This is the first time I've had any issues with my laptop in 2 years so starting to feel worried :(
     

Share This Page