Apps for 2nd gen iPod Touch???

Discussion in 'iPod touch' started by embalmess, Dec 24, 2009.

  1. macrumors member

    Aug 20, 2008
    So it seems many of the games on my iPhone are not compatible with my son's new hand-me-down iPod Touch, 2nd Generation... in iTunes I tried typing in "iPod Touch" but very limited games. Any ideas? I would like it to go under the tree loaded with lots of neat games for him :rolleyes:

  2. macrumors 6502a

    Jan 20, 2008
    Nearly every application in the App Store is compatible with the iPod touch. The only ones that aren't are ones that require the use of a camera.
  3. macrumors G3


    Apr 6, 2007
    Portland, OR
    Or the GPS
  4. macrumors 6502a

    Jan 20, 2008
    No, GPS is fine. It uses triangulation instead.

    Although augmented reality apps won't work (they require the magnetometer)
  5. macrumors 68040

    Jan 11, 2007
    North Central Florida
    Is the touch maybe not running 3.0? That would make a difference in what runs. A lot of apps are requiring it now.
  6. macrumors regular

    Dec 4, 2008
    I'm not sure "iPod Touch" is a good enough search term in the iTunes store. I think if you searched with a phrase closer to what you want the app to do would return far more results. The app should also say if it required 3.0 or not.

    Also, any app that requires sound input will require some sort of microphone.

Share This Page