Apps will not launch on my 3GS

Discussion in 'iPhone' started by sootie, Aug 14, 2009.

  1. macrumors member

    Jun 17, 2009
    So yeah I have a iPhone 3GS and have had it since launch with very few and very minor problems up until 2 days ago.
    I was messing around at work and facebook crashed but I paid it no mind and just put it to sleep so then when I came back to check facebook again and it jst flashed the home screen of facebook and instantly returned to the phones homes screen. So at this point I figured it was just a app problem and I reinstalled facebook and it Still wouldn't launch.
    So then I tried to launch several other apps all of which failed to launch as well. So then I did a hard reset (sleep/wake + home) still no app would launch. So then I took the phone home and did an update to 3.0.1 and still no app would launch. So then I did a restore and update. Reinstalled all apps and still no app launched. Also a side note the only apps that work are apples base apps like phone, messages, mail, calculator , etc.

    Any thoughts on what the problem could be? I'm taking it to the genius bar on saturday I guess it's a hardware issuse since restarts and restores have no effect.
  2. macrumors P6

    Jun 22, 2009
    I wouldn't say it's a hardware issue with certainty. Have you tried removing ALL the apps and adding one at a time to see if just that one or a few will open. Clearing the phone and putting EVERYTHING back isn't going to give you an answer.

    Try removing all the apps - reset and only load one app to start
  3. macrumors member

    Sep 15, 2008
    You need to unauthorize your computer and reauthorize. Not sure if you have to remove the apps first before doing the previous. I've personally done this to fix it.
  4. macrumors P6


    Jun 19, 2009
    Where bunnies are welcome.
    That's one of the fixes. Sometimes adding an app fixes it as do the other suggestions. It's NOT a hardware issue. There are several threads on this issue, FYI.

Share This Page