Apps with ?

Discussion in 'Mac Basics and Help' started by jariev202, Sep 17, 2006.

  1. jariev202 macrumors newbie

    Joined:
    May 6, 2005
    #1
    Hi, I have all my applications with a ? over them. What does that means? Should i get worried?

    I added a picture of one of my apps so you may know what i mean.

    Any answer appreaciated :)

    thanks!
     

    Attached Files:

  2. GimmeSlack12 macrumors 603

    GimmeSlack12

    Joined:
    Apr 29, 2005
    Location:
    San Francisco
    #2
    Very strange. I've never seen that before. What happens when you open any of these Apps with a Question Mark? Repair permissions?
     
  3. jariev202 thread starter macrumors newbie

    Joined:
    May 6, 2005
    #3
    I did repaired permissions and even ran diskwarrior with no problems found but I still have that little ? over all my apps. The apps for the moment open fine. I have osx tiger with all updates ina powerbook g4.
     
  4. elisha cuthbert macrumors 6502a

    elisha cuthbert

    Joined:
    Feb 25, 2006
    Location:
    Melbourne
    #4
    maybe a reinstall, archive and install
    that might help
     
  5. emptyCup macrumors 65816

    emptyCup

    Joined:
    Jan 5, 2005
    #5
    Do these icons appear over the actual application, or only in the Dock?
     
  6. dunc85 macrumors regular

    Joined:
    Jul 23, 2006
    #6
    http://docs.info.apple.com/article.html?artnum=151940

    If you delete an application or document that has an icon in the Dock, the Dock icon changes to a question mark.
    To remove the question mark icon:

    Drag it from the Dock.

    To add a new item to the Dock, locate the item and drag its icon to the Dock.


    When you say they load fine, does that mean they run when you click the Dock icon?
     
  7. elisha cuthbert macrumors 6502a

    elisha cuthbert

    Joined:
    Feb 25, 2006
    Location:
    Melbourne
    #7
    different type of question mark here
     
  8. srf4real macrumors 68030

    srf4real

    Joined:
    Jul 25, 2006
    Location:
    paradise beach FL
    #8
    Is your computer an Apple? Looks like some sort of identity crisis or something.:confused: I'v never seen that question mark anywhere in any Apple OS before!
    Definitely erase and install.
     
  9. elisha cuthbert macrumors 6502a

    elisha cuthbert

    Joined:
    Feb 25, 2006
    Location:
    Melbourne
    #9
    erase and install??!!?!?!?
    why not start with an archive and install and then go to a more definite installation method
     
  10. srf4real macrumors 68030

    srf4real

    Joined:
    Jul 25, 2006
    Location:
    paradise beach FL
    #10
    I'm thinking that particular question mark should not exist on ANY Apple OS... unless the OS has been compromised in some way. Backup... Erase... Install!
    or is it a pc:confused:
     
  11. jariev202 thread starter macrumors newbie

    Joined:
    May 6, 2005
    #11
    Thanks for all the answers. Of course my computer is an apple computer, a really nice powerbook g4. with 10.4.7 installed. The ? over the apps is not over the icons in the dock. It's over all the apps in /applications folder. I have discovered that they stay like that for some time (some restarts) and then they are gone to be back later (don't know yet why they come back). I've been thinking if I had installed or done something to comprimise the system, but it's been a while I have kept my computer untouched (no new installs, only work with documents)

    I wish I didn't had to reinstall !!!
     
  12. Jaffa Cake macrumors Core

    Jaffa Cake

    Joined:
    Aug 1, 2004
    Location:
    The City of Culture, Englandshire
    #12
    Before you do anything too drastic, it might be an idea to log in as a different user to see if the problem still continues.

    I have to say though, I've not seen this particular problem before. :confused:
     
  13. jariev202 thread starter macrumors newbie

    Joined:
    May 6, 2005
    #13
    Using a different user doesn't help :( Really strange that little ? over my apps though they still seem to work with no problems.
     
  14. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #14
    Are you using any utilities that modify system behavior in any way? Anything like Candybar, Uno, etc? I too have never seen this kind of question mark icon before....
     
  15. seanf macrumors 6502

    Joined:
    Aug 8, 2006
    Location:
    UK

Share This Page