AppStore:"The code you entered is not recognized as valid code" (or Already Redeemed)

Discussion in 'OS X Mountain Lion (10.8)' started by sevimli, Jul 25, 2012.

  1. sevimli, Jul 25, 2012
    Last edited: Jul 25, 2012

    macrumors 6502a

    Joined:
    Jun 26, 2007
    #1
    I got my code yesterday while up-to-date program was online for a short time. I am not using the reference number, I received my real redeem code, but it just won't work.


    Anyone else?

    (This is in US App Store)


    Thanx
     
  2. macrumors 6502

    Joined:
    Apr 11, 2012
    #2
    I'm having problems as well. It keeps telling me that the code has has already been used...
     
  3. macrumors newbie

    Joined:
    Feb 27, 2008
    #3
    Having the same problem. Got my code Monday and now the AppStore won't redeem it. I tried going through the Up-to-Date process again and it said my serial number was already processed. Assume this will get fixed. If it goes on for much longer, it's worth a story on MacRumors. That will get Apple's attention, though I'm sure they know about it.
     
  4. macrumors 6502a

    Joined:
    Oct 21, 2011
    #4
    There was an issue where the up to date program was released early for some people. Apple have said people who got the code early will be issued a new one after ML is officially released.
     
  5. G15
    macrumors member

    Joined:
    Dec 24, 2011
    Location:
    Weimar, Germany
    #5
    Same hear (Germany).
    It says: your Code is been used, you only can use it ones.
     
  6. macrumors newbie

    Joined:
    Feb 27, 2008
    #6
    Cool, thanks for the tip. Where did they say this?
     
  7. macrumors newbie

    Joined:
    Jun 19, 2010
  8. macrumors 6502

    Joined:
    Feb 26, 2011
    Location:
    Oklahoma
    #8
    Well I got mine this morning (after the official release) and it still says that my code has been used before. I'm having that same feeling I did when MobileMe came out.
     
  9. macrumors newbie

    Joined:
    Apr 4, 2008
    #9
    I just submitted mine this morning and mine said it was already redeemed, I sure did not use it?
     
  10. ugp
    macrumors 65816

    ugp

    Joined:
    Jan 7, 2008
    Location:
    Inverness, Florida
    #10
    I am getting the same problem. Says the code has already been redeemed.
     
  11. macrumors newbie

    Joined:
    Jun 13, 2012
    #11
    I got my code 2 days ago and mine is invalid also. I just called up applecare about 30 minutes ago and told the guy my situation and he had me try to redeem it again but it said it had already been redeemed. He then said that his system had a note in it saying that anyone who redeemed their serial number and got one of the invalid codes should recieve another email within one business day after mountain lion was released (already happened so the time is ticking now).
     
  12. thread starter macrumors 6502a

    Joined:
    Jun 26, 2007
    #12
    There is not such a thing.

    The source: Husbands uncle, who has a friend working in MS store.
     
  13. macrumors newbie

    Joined:
    Oct 16, 2006
    #13
    Yep me too... there is definitely a problem here...or someone stole a whole lot of codes.
     
  14. kis
    macrumors 6502a

    Joined:
    Aug 10, 2007
    Location:
    Switzerland
    #14
    well, I got my code through official channels AFTER ML was released and I still can't redeem it. What gives?

    The system tells me that my code isn't valid.
     
  15. macrumors 68020

    Joined:
    Nov 3, 2008
    #15
    I also did the Up-to-Date thing and the password protected code they gave me says it was used. Spoke with Apple Support and they claimed "several customers codes were sent in error and you should receive a new code within 30min".

    I hate to say it, but phone support and a bunch of hoop jumping just to get OS validation makes me feel like I'm back on Windows.

    Edit: It's been 30min and i got nothing new so I have no idea whats going on.
     
  16. macrumors regular

    Joined:
    Jun 19, 2012
    #16
    Same problem...I even received a second code but that one doesn't work either. Greeeaaaat
     
  17. kis
    macrumors 6502a

    Joined:
    Aug 10, 2007
    Location:
    Switzerland
    #17
    I was thinking the exact same thing...
     
  18. macrumors newbie

    Joined:
    Jul 25, 2012
    #18
    This code has already been used

    I got the same error at Brazilian App Store, "This code has already been used". This is certainly something related to the early release of the Up to Date Form.
     
  19. mello7, Jul 25, 2012
    Last edited: Jul 25, 2012

    macrumors newbie

    Joined:
    Jul 25, 2012
    #19
    same thing happened in indonesia, maybe they want to limit the update in the first day?? server issue?
     
  20. macrumors regular

    Joined:
    Jan 24, 2007
    #20
    I too got the "This code has already been used..." response. Apparently someone is hoarding all these free copies of ML.

    Bastard.

    Calling AppleCare to see if they can sort anything out. So far the guy read me a copy of the letter they got yesterday when the program went live for a brief period of time but I informed him that I didn't register until 15 minutes ago after the official launch. Waiting for a Senior Advisor.
     
  21. macrumors newbie

    Joined:
    Oct 24, 2007
    Location:
    Manchester, UK
    #21
    i filed my claim TODAY on the website after it went live. not during the brief uptime yesterday. code says that it's been used. dang...
     
  22. macrumors newbie

    Joined:
    Jun 13, 2012
    #22
    I was told up to a whole business day, not just 30 minutes.
     
  23. macrumors 65816

    Joined:
    Feb 24, 2009
    #23
    My code says it has already been used. What a headache.
     
  24. urkel, Jul 25, 2012
    Last edited: Jul 25, 2012

    macrumors 68020

    Joined:
    Nov 3, 2008
    #24
    Does anyone know if Mountain Lion is serial number specific? If its really going to take a full day just to validate a purchase/computer then would a Genius Bar be allowed to simply verify a receipt and then install it for us?
     
  25. macrumors member

    Joined:
    Jun 27, 2012
    #25
    same for me here...says this code was already used :(

    will wait one day, as advised
     

Share This Page