Arabic on OSX

Discussion in 'macOS' started by jne381, Jul 8, 2006.

  1. jne381 macrumors regular

    Joined:
    Feb 27, 2006
    Location:
    Grand Rapids
    #1
    I was wondering if anyone has had this problem, or knows how to fix it?

    I have been studying Arabic over the Summer at University, and I don't know how to get it to display properly on my computer. I am running 10.4.7 and any Arabic words on a word documents come out separated. The same thing occurs on the BBC Arabic Website. Al Jazeera however appears to be normal, but I suspect that it is just the way it is set up on the website, and not giving my computer the chance to mess it up.

    Thankfully I have a Mac and have never had to deal with problems of this insignificant of a nature before, usually because it always seems to work all by itself, but it leaves me in the dark when I actually do need to fix something.

    Any help would be appreciated.
     
  2. gekko513 macrumors 603

    gekko513

    Joined:
    Oct 16, 2003
    #2
    It's usually a problem with the website. Sometimes it can be fixed by changing the text encoding in the View menu in Safari.

    Wait, do you mean that the letters aren't properly joined into words? I've seen that problem, too. I don't know what causes it.
     
  3. jne381 thread starter macrumors regular

    Joined:
    Feb 27, 2006
    Location:
    Grand Rapids
    #3
    Yes, the letters are not connected into words. Moreover, the BBC website comes up properly on my friends Windows PC. More importantly, Arabic in Word documents also has the unconnected problem on my computer.
     
  4. gekko513 macrumors 603

    gekko513

    Joined:
    Oct 16, 2003
    #4
    If I should make a guess OS X has implemented correct behaviour for text that follows normal Unicode standards, but Microsoft has invented something of their own or uses the standards in a an awkward way. Since Microsoft has so much market share, the non-standard usage becomes much used and that makes it difficult for others like Apple to keep up.

    I could be wrong and it's all Apple's fault for having a lacking implementation of the text rendering engine.

    You should report it to Apple, but it would be interesting but a bit time consuming to study what kind of encoding causes the problem and what kind doesn't. How does it work for you when you type Arabic in TextEdit? For me it works fine.

    If we could figure out when exactly the problem occurs, we could file a more meaningful report to Apple.
     
  5. gekko513 macrumors 603

    gekko513

    Joined:
    Oct 16, 2003
    #5
    I found the problem, I think. It's font related. Look at the attached image. I tried to write something in TextEdit and it looked fine, then I copied the same word from an internet page where it displayed incorrectly. Everything I wrote after that continued to display incorrectly. At first I couldn't understand why, but then I though about checking the font, and indeed I found that if I changed to font to Geeza pro of something that displayed incorrectly in Arial, it would display correctly.

    Also, I just tried Firefox and it doesn't seem to suffer from the same problem.

    Edit: I just sent feedback to Apple about this. If you also do it, that might increase the chances of us being heard.

    2nd Edit: I found a solution for Safari over at support.apple.com. Disable Arial and Times New Roman in FontBook. Someone also wrote that Office for Mac OS X doesn't support Arabic, so you'll have to use TextEdit, Mellel, Nisus Writer Express, AbiWord, or NeoOffice/J. Pages would probably also work.
     

    Attached Files:

  6. jne381 thread starter macrumors regular

    Joined:
    Feb 27, 2006
    Location:
    Grand Rapids
    #6
    Thanks for the suggestions. I have been able to get by with the help you have provided.

    I can run Camino to pull up the web pages in Arabic. Unfortunately, I can't get a Word document to display correctly, even when I change the font to Geeza Pro. But I can cut and paste into Text Edit and it displays correctly in that. I have never really used Text Edit, but I guess I'll have to get used to it.

    I have not become proficient enough at Arabic to worry about writing on a computer yet, but I may be in about six more weeks.

    Thanks for the help so far.
     
  7. gekko513 macrumors 603

    gekko513

    Joined:
    Oct 16, 2003
    #7
    You're welcome. Perhaps we should send feedback to Microsoft instead and ask for Arabic support in the next Office version.
     
  8. jne381 thread starter macrumors regular

    Joined:
    Feb 27, 2006
    Location:
    Grand Rapids
    #8
    I just disabled Times New Roman and Arial in Safari, and it appears to have worked. i wonder how it will effect the rest of my applications.

    It is a bummer that Mac Office doesn't support Arabic, I guess I will become very good at Text Edit.

    Consider feedback already sent to MicroSoft.

    Thanks again.
     
  9. gekko513 macrumors 603

    gekko513

    Joined:
    Oct 16, 2003
    #9
    It shouldn't affect other applications much, except perhaps Microsoft Office, since those two fonts don't come with Mac OS X, but are installed by Microsoft Office.

    I think Microsoft Office should be able to handle it by using other very similar fonts, like Helvetica and just Times.
     
  10. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #10
    Which version of Office are you using?
     
  11. emptyCup macrumors 65816

    emptyCup

    Joined:
    Jan 5, 2005
    #11
    All of the word processors mentioned by Gekko513 are better than Text Edit. Personally, I use Mellel, which I think is worth the $50. You can can check it out here. Actually, you can check them all out at Version Tracker or MacUpdate.
     
  12. gekko513 macrumors 603

    gekko513

    Joined:
    Oct 16, 2003
    #12
    I don't use Office. I had a test drive of Office 2004 that came with the MBP, for a while, though. The apple support forum member that wrote this claimed it was caused by Office 2004 installing those fonts.

    Link

    Edit: Oh, and by handle it I didn't mean handle Arabic, I ment handle getting by without those two fonts.
     
  13. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #13
    I don't read Arabic so I didn't want to say anything before, but I think by comparing what the BBC homepage looks like in Camino vs. Safari, I can see the difference, and looking at the stylesheet that page uses, the problem is obvious.

    Basically, here's the font list for the BBC, taken from their stylesheet:

    The problem comes way down at the end, where they for some inexplicable reason throw in "Arial" and "Helvetica" as defaults if none of the long list of specific Arabic font variants they've specified exist on the user's system.

    The problem is, while Camino apparently knows what do do in this situation (I'm guessing because it's based on the Gecko engine, or has its own font rendering scheme), Safari dutifully uses Arial, which has no Arabic characters in it. What the MacOS does by default in this situation is substitute individual glyphs from a font that does have them.

    This would be fine in, say, Japanese, where you have one glyph per letter, and no connection between them. In Arabic, it results in non-functional word spacing, since the language appears to rely on what are in effect a bunch of ligatures to display words properly.

    If you remove the errant fonts from your system, Safari will properly default to a font that DOES support proper Arabic rendering, and it looks fine--you're basically forcing it to ignore the bad design of the BBC's css stylesheet.

    Here's an alternative workaround that SHOULD work; you can just explicitly tell Safari to use a proper font by overriding with your own personal stylesheet.

    This one line of css should more or less take care of it; at least, it appeared to cause the BBC page to render properly to my completely untrained eye:

    Code:
    body,a,div,td,h1,h2,h3,h4,h5,strong,b,em,i,blockquote {font-family: "Geeza Pro" ! important;}
    Basically paste that one line of text into any raw text file (for example, Text Edit with "Make Plain Text" turned on), then save it as YourFileName.css.

    Then, go into Safari, under the Advanced preference, and select it for your style sheet. The text on the page will instantly switch to using Geeza Pro (or whatever font you specify), and looking ok. It doesn't do that much damage to the English pages I tried, but you can turn it off instantly by selecting "None Selected".

    Safari should probably have a slighly more graceful way of failing than this, but it's not EXACTLY an Apple bug; technically, it's behaving correctly for an app that uses Apple's (very good) completely multilingual text engine.

    There's a vaguely related problem that can be caused by trying to use italics in a font that has no italicized variant that I documented a while ago.

    Oh, and I'll second the recommendatino for Mellel; I generally just use TextEdit, but if I wanted more and didn't get a free copy of Word with my job, it would be what I use.
     
  14. gekko513 macrumors 603

    gekko513

    Joined:
    Oct 16, 2003
    #14
    Thanks Makosuke. That was a very informative post.
     
  15. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #15
    You're welcome--hopefully it'll do somebody some good.

    I did forget to mention that personally, I'd just use Camino anyway, though--I switch between it and Safari periodically, but Camino has been my main browser for a long time, and it appears to handle these pages gracefully without resorting to a custom stylesheet.
     

Share This Page