Artists listed, for same songs, multiple times?

Discussion in 'iPod' started by eddorey2k3, Mar 31, 2007.

  1. eddorey2k3 macrumors newbie

    Joined:
    Feb 27, 2007
    Location:
    England.
    #1
    Hey,

    I've synced my iPod with my MBP, and it's copied the same songs, by the same artists, but lists them multiple times.

    I have restored the iPod and resync'd it. It still does it.
    For example,

    I have

    Atreyu
    Atreyu
    Atreyu
    Atreyu
    AFI

    The genre's of the music is the same, and there are no spaces (in the name).

    Any ideas?

    Edit: They're the same song. Not duplicates, just multiple links to the same song.
    They're also only listed in iTunes once.
     
  2. WillJS macrumors 65816

    WillJS

    Joined:
    Jan 6, 2007
    #2
    If they are duplicates:

    View --> Show duplicates --> Delete all but one.
     
  3. tveric macrumors 6502

    Joined:
    Jun 23, 2003
    #3
    Pretty sure that's not what this guy was asking.

    I have the same problem.... I think. Pearl Jam is listed twice in my ipod's "Artist" list - no spaces in the name in any of the songs' ID3 info, and every CD and every song is listed under each "Pearl Jam" in that list. There are no dupes in iTunes.

    Anyone else seen this, or know how to fix it?
     
  4. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #4
    I had this problem on my previous sync... I had added a couple of songs by Biggie, and I saw this on my iPod:

    ...
    Notorious B.I.G.
    The Notorious B.I.G.
    Notorious B.I.G.
    The Notorious B.I.G.
    ...

    Under the first and third listings were the new songs, and the second and fourth had the old ones. :confused: As described, in iTunes, there were two (but not four) artist entries -- one with "The" and t'other without.

    After that, I went in iTunes and fixed the new songs so that the artist matched the old ones, and re-synced.

    Now I'm back down to just the one entry. But I've really no idea why even the old "artist" was appearing twice?
     
  5. tveric macrumors 6502

    Joined:
    Jun 23, 2003
    #5
    The problem is, what if you've tried that, and you still have 2?

    My ipod shows:

    Pearl Jam
    Pearl Jam

    No difference, no spaces. I temporarily renamed the artist in every Pearl Jam song to PJ, synced, then renamed them to Pearl Jam again, by editing info for every song at the same time (select all, Command-I), and still, in my ipod:

    Pearl Jam
    Pearl Jam

    Every CD listed, with every song, for both entries.

    wtf??
     
  6. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #6
    Do they all have the same genre? Also try putting Pearl Jam in the Album Artist tag for all of them and/or blanking the Album Artist field if it's full now?
     
  7. tveric macrumors 6502

    Joined:
    Jun 23, 2003
    #7
    Tried both - Album Artist appeared to be blank but I didn't go thru and check each one individually, so I entered Pearl Jam into all of them - same thing happened. Then I deleted Album Artist info for all tracks - same problem.

    They don't all have the same Genre, but there's more than 2 genres, also don't see why that would cause it - it doesn't happen in any other artists that have multiple genres in different tracks.
     
  8. tveric macrumors 6502

    Joined:
    Jun 23, 2003
    #8
    So, I got it to work - although I still don't know why it happened in the first place.

    I ended up checking, under "sync music", the "Selected playlists:" option. I had a smart playlist that was all-Pearl-Jam, so I left that one unchecked and checked the rest. Did a sync (which, in effect, removed all Pearl Jam songs from the ipod), then went back to syncing "All songs and playlists", and that forced a re-copy of the Pearl Jam songs to the ipod. Result: one Pearl Jam item in the artists' listing.

    Success, without knowing why. It's bedtime.
     
  9. travisty1 macrumors newbie

    Joined:
    May 9, 2007
    #9
    I think I figured this out

    Abstract: My solution was to go to "get info" for each song for any particular artist, find the "sorting" tab, and make sure the "artist" field is exactly the same for each song for any artist. Any differences will cause each difference to end up making another listing.


    My ipod was having a similar situation, but sometimes having up to 15 different listings for the same artist. It was starting to get out of hand. I had just added a bunch of music, and all of a sudden all sorts of artists had multiple listings. I was about to blow my lid, but I think I figured out a solution:

    In the basic iTunes list, scroll to the first song of an artist that has multiple listings. Now on my PC, I would right click on that first song and select "get info".

    In the dialog box that appears, choose the tab: sorting.
    This is where I found my problem.
    If within any given artist across all songs for that artist, if I had more than one different listing under "sort artist", I got at least 2 listings, possibly more depending upon the number of various "sort artist" fields that were filled in for all of that artist's songs.

    For instance, if I select my "A Perfect Circle" songs and find that one has nothing in the "sort artist" field, but then another song or full album has "Perfect Circle, A" in it, and another album or song has "A Perfect Circle" in there, it will create no less than 3 listings on my ipod.

    Edit: I was searching google to fix this problem, and this was the best result that came up for me. Since it wasn't resolved by more than 1 user, I decided to register and post. Please let me know if this worked for you . . . it worked for me!
     
  10. Eleventh macrumors newbie

    Joined:
    Mar 15, 2008
    #10
    It is, in fact, a problem with discrepancies in the "Sort Artist" field. A good way to fix this problem is to open up your iTunes library and right click the column headings. Check "Sort Artist" to see for yourself. Some will be blank and others will be different ("Bill Hicks", "Hicks, Bill", etc.). Just pick one song for each artist that has the Sort Artist you desire and then right-click it (or whatever the mac equivalent is) to get that right-click menu. Then go to the bottom to "Apply Sort Field >" and click "Same Artist". This will then propagate the Sort Artist for that song you right-clicked to all songs with that Artist. Now sync your ipod and you'll notice that duplicates for that artist have gone away. Yay.
     
  11. usermammal macrumors newbie

    Joined:
    Dec 21, 2010
    #11
    sort artist didn't work for me

    I tried the "sort artist" solution, deleted those tracks from my iPod, and reloaded them, and it's still happening. What else might be causing this stupid, stupid error?
     

Share This Page