At Hilton-Americas Hotel, Can't Connect!

Discussion in 'Mac Basics and Help' started by Moof1904, Jun 26, 2006.

  1. Moof1904 macrumors 65816

    Joined:
    May 20, 2004
    #1
    Help!

    I can't get the wired ethernet connection in my hotel room to work. I've been on the phone with "Datanamics" (the provider to this Hilton Hotel) and still can't connect.

    I've been to a zillion hotels and hotspots and never had a problem. I've tried:

    -swapping ethernet cables
    -creating a new location and making sure Ethernet/DHCP was selected
    -rebooting
    -turning my firewall off (though that didn't seem like it could cause a connection issue)
    -cursing

    Attached is a screen shot of my network config screen. Clicking Apply or clicking Rener DNCH lease does nothing. I still can't get an IP address.

    The hotel tech support guy came to my room and was able to connect using his WIN XP laptop.

    Any ideas? (BTW, I'm connected now to the wireless network that's so horribly out of range that I keep losing the signal every few seconds. Wireless isn't a viable option.)
     

    Attached Files:

  2. benthewraith macrumors 68040

    benthewraith

    Joined:
    May 27, 2006
    Location:
    Miami, FL
    #2
    Hmm, first make sure Windows sharing is on (not that I think that would matter). You could also try forcing the IP address, though I don't know how in Mac to do that. You would also need a DNS server (lookup the nearest uni to you). That's all. :)
     
  3. Queso macrumors G4

    Joined:
    Mar 4, 2006
    #3
    I've had this one before. The DHCP server isn't responding quickly enough, so your Mac is going to an autoconfig 169.254.x.x address. Windows waits a lot longer than the Mac for a DHCP response, which explains why XP connects fine. Click like mad on the Renew DHCP lease button for 10 seconds. That way when the response comes in, your Mac will still be listening for it.
     
  4. benthewraith macrumors 68040

    benthewraith

    Joined:
    May 27, 2006
    Location:
    Miami, FL
    #4
    Or you can do that. :eek:
     
  5. Moof1904 thread starter macrumors 65816

    Joined:
    May 20, 2004
    #5
    More and more strange

    I gave up connecting with wired Ethernet at the Hilton and just went to a spot in the hotel where the wireless signal strength was sufficient, thinking that this isolated failure to connect via wired was merely an anomaly.

    On the way home, I spent the night at a friend's house. Friend has wired Ethernet throughout his house with a mixture of Macs (well, one MBP) and PCs. I plugged into his Ethernet and couldn't connect there either!

    Friend looked at his router and said that there was no indicator light that would indicate that the router saw any kind of electrical activity on that Ethernet port at all. So, I figured that the Ethernet on my tired, old laptop had died. (500Mhz Ti G4 PB).

    I got home, plugged the PB into my Ethernet at home and it works perfectly.

    WTF!?!?!?!

    What's going on that I can suddenly connect only at home and not at other seemingly fine wired networks?

    I'll be traveling again soon and I'd love to solve this before I leave.

    Any ideas?
     
  6. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #6
    Well, there's clearly SOMETHING wrong with your Ethernet port.

    I was going to suggest that maybe it was a problem with the way your locations were set up--for example, your "travel" location has the ethernet port disabled (which would kill power to it and make it look as if it were broken), while your home one has it on (so it works at home).

    But, from the looks of your screenshot, you created a Hilton location that obvioiusly has Ethernet enabled. I don't suppose you accidentally forgot to click "Apply Now" or something... but no, rebooting would have prompted you to save and apply the settings. Does't seem like accidentally setting it to a fixed speed would do that, either.

    The only other thing I can think of is that there's something wrong with your port but either the cable you're using at home works around it, or your home router is forgiving of the problem. Have a look inside the port--I have seen situations where the pins get bent out of shape and it won't work. Perhaps your home cable fits in such a way that it makes contact, while others don't?

    Otherwise, I can only think that it's an intermittent problem and you just got lucky when you got home.
     
  7. Moof1904 thread starter macrumors 65816

    Joined:
    May 20, 2004
    #7
    Thanks. I'll try shining a bright light into my port (!) and see if there are any bent pins there or anything. I tried two different cables at the hotel (one of which worked with the hotel IT guy's PC laptop) and neither worked, so I don't think it was merely a cable issue.

    The router I have at home is an Airport Extreme Base Station that has its LAN port attached to a DLink switch to serve a bunch of ports throughout the house. I don't know enough about this to know of a hardware problem that my router would forgive, but other routers would not.

    BTW, I created a brand new account on my laptop and tried to connect at my friend's house using that and it didn't work either.

    Grrrr.
     
  8. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #8
    Well, I see no reason the ABS would be "nicer" on its LAN port than a hotel network or home router, but it is possible at least in theory. Certainly, if your friend's router didn't even see a device attached, there's something significantly wrong.

    My money is on a flakey port/chip that just happened to kick back in when you got home, but you never know--anybody who lives nearby and has a LAN you could plug into and check?
     
  9. Moof1904 thread starter macrumors 65816

    Joined:
    May 20, 2004
    #9
    The pins look absolutely perfect. No misalignment or missing pins.

    I'll check around and see if I can plug into someones lan to investigate further.

    Thanks for your continued assistance.
     

Share This Page