Resolved ATI Radeon HD 6870 Help Required.

Discussion in 'Mac Pro' started by Washac, May 10, 2013.

  1. Washac, May 10, 2013
    Last edited: May 11, 2013

    macrumors 68020


    Jul 2, 2006
    I have installed an ATI Radeon HD 6870 in my Mac Pro and installed kext file that came from Cindoris package and yes i did only install the kext file and nothing else.

    Everything I have run has worked OK no problems at all, now I have run into a game that has issues.

    A report of my machine was sent of to the games company who replied with that my machine shows a non official driver for my card and basically says until I fix this issue they cannot help me.

    Any help would be good.
  2. macrumors 6502

    Feb 27, 2013
    what game? also what version of OSX?
    is the 6870 flashed with EFI?
  3. Washac, May 10, 2013
    Last edited: May 10, 2013

    thread starter macrumors 68020


    Jul 2, 2006
    The game is XCOM Enemy Unknown Elite for Mac
    Mountain Lion 10.8.3
    No flashing
  4. macrumors 68040


    Dec 7, 2009
  5. thread starter macrumors 68020


    Jul 2, 2006
    I have removed the ATY_init.kext

    I used this - sudo kextunload /System/Library/Extensions/NAME_OF_THE_KEXT_FILE.kext

    Do not know how to flash it, and a bit nervous about messing things up, any guidance would be good.
  6. macrumors 65816


    Mar 17, 2007
    There should be more than enough of the information needed on the site link below. Who knows perhaps you will get lucky like I was and there will be a pre-made ROM already there for your card for you to flash it with.

    Edit: Oh and you left out.
    sudo rm -rf  /System/Library/Extensions/NAME_OF_THE_KEXT_FILE.kext
    To actually remove the .kext not just unload like you did, your way left it there for it to reload on next boot.
  7. macrumors 6502a

    Nov 25, 2012
    This is the specific link explaining everything about flashing the 6870. You need to register to see and download the necessary EFI portion of ROM attached to the first post.
  8. Washac, May 10, 2013
    Last edited: May 10, 2013

    thread starter macrumors 68020


    Jul 2, 2006
    Thanks for the link, been there before I just get lost, and do not know how to flash, I just seem to find blocks of coding stuff :(

    I need it work under 10.6.8 - 10.8.3 and Bootcamp.

    Read on Nektas that somebody flashed their ATI Radeon HD 6870 now it does not work right under 10.6.8

    I'm confused.
  9. macrumors 6502

    Feb 27, 2013
    post your original ROM from the card, do you have bootcamp installed?
    if you have bootcamp\Windows then download "GPU-Z" and use that to extract the original bios.
    Post it here and I'll convert it to EFI for you, then you can flash the card.
  10. macrumors 6502


    Mar 1, 2010
    Probably should just use a card designed to work with a mac if you are unable or unwilling to learn how to flash the 6870.
  11. Washac, May 11, 2013
    Last edited: May 11, 2013

    thread starter macrumors 68020


    Jul 2, 2006
    Hey this sounds good, I do use Bootcamp so I will give this a go later today, thank you for this really appreciated :)

    Edit: OK, first part done, had to change the . rom to .txt so I could attach it.

    Attached Files:

  12. macrumors regular


    Jul 7, 2005
    In the Nexus.
    Did you really remove the kext like MacUser2525 recommended? And then rebooted your system to 10.8.3?

    Otherwise there might be a chance that you load some old driver like edddeduck estimated in the XCOM thread. Which would result in the problems, you described there.
  13. macrumors 6502

    Feb 27, 2013
    I made the ROM, check your PM.

    Make sure the ati card is the only card installed, in the bottom slot (slot 1)
    Also use the White DVI Port (beside the hdmi and mini display ports, don't use the DVI port that is alone on the top)

    You can flash in OSX using Zeus 2.3 or in Windows using ATI_winflash

    Zeus 2.3:
    ATI Winflash:

    I would try Zeus in OSX first because it's easier.

    In Zeus under the ATI section at the bottom just select the ROM I made, then for OS select Snow Leopard and hit flash.

    For ATI Winflash here are instructions:

    basically in Windows open a DOS prompt with admin rights (right click on CMD prompt -> Run as Admin

    when the dos prompt opens, change directory to wherever AT_winflash is:
    "cd\users\*user name*\desktop\ati_winflash_2.3.0" as an example

    then run:
    atiwinflash -f -p 0 6870EFI.ROM

    it should flash, then shutdown and restart in OSX.

    Also the .kext file you messed with, you didn't have to, it should work natively in OSX without messing with any .kext
    When I had a flashed 6870 in Mountion Lion I had no issues, never had to touch at .kext, it worked out of the box.

    I would put the .kext back and add\remove any .kext files you messed with when trying to make the card work. Then run the 10.8.3 combo update after to repair any .kext files.

    I had steam, dvd player, all my games working without touching any .kext files.
  14. thread starter macrumors 68020


    Jul 2, 2006
    Many many thanks for doing the file and the above instructions very clear indeed :)

    I have a couple things, the first one being the obvious.

    Using the DVI means I need to buy a DVI to Mini Display Port adapter, not looked yet but I assume this does exist.

    The card I have did/does work out of the box, I only added the .kext under recommendation in case some programs did not work, I have under your recommendation removed the kext, it was the only one I had installed or messed with.


    Yes I removed that kext file as recommemded by Macuser2525, not booted back into 10.8.3 since doing so yest, will try soon.
  15. macrumors 6502

    Feb 27, 2013
    you can try using the Mini Display Port, I'm just not sure if you'll get boot screens, I know for sure the DVI port beside the Mini Display Port will show boot screens.

    I just e-mailed you the ROM, let me know if it works!
  16. Washac, May 11, 2013
    Last edited: May 12, 2013

    thread starter macrumors 68020


    Jul 2, 2006
    All done and all OK, sent you an e-mail :)

    The game still freezes but not quite so much but I think that is down to playing with the game settings rather than my machine.

Share This Page