ATV 2 & Netflix HDCP issues

Discussion in 'Apple TV and Home Theater' started by djuarez03, Feb 2, 2011.

  1. macrumors regular

    May 23, 2008
    This week, I started to get the HDCP error message when trying to watch Netflix on the ATV 2. It used to work fine before, but now, nothing I do gets rid of the error. I tried switching cables, turned off & on the equipment every which way to troubleshoot handshake issues, reset the ATV 2, and even restored the software and started from scratch, and still nothing! I keep getting the HDCP message everytime I try to watch Netflix. I've run out of ideas already. I have my ATV 2 hooked up directly to my TV. My TV only has one HDMI port, so can't even try switching ports. Anyone have any suggestions? I don't have any other TV's I can test it with that have an HDMI port. PLEASE HELP!
  2. macrumors 6502a


    Mar 3, 2009
    San Diego, CA
    What changed in your hardware setup? Did you recently update the aTV's firmware? Also, if your TV only has one HMDI port, it's probably an older model that could have troubles with HDCP. My suggestion would be to update the firmware to the latest version on your aTV (and TV, if you can) and if that doesn't work, try it out on a friend's TV. HDCP is DRM. DRM sucks. Sorry for your trouble. :(
  3. thread starter macrumors regular

    May 23, 2008
    Nothing had changed in my setup, it just stopped working all of a sudden. Like I said, I restored the firmware already, and it didn't help. I do have an older tv, it's a toshiba projection tv, and if it's the tv that's the problem, then I guess I'll have to buy a new one in the near future :(
  4. macrumors newbie

    Feb 5, 2011
    Had similar issue on noHDCP display (which is normal), after i bought HDfury, the issue is no more. It gave new live to my 65inch Mits RPTV

Share This Page