Atv Sata mod question

Discussion in 'Apple TV and Home Theater' started by BORIStheBLADE, Sep 23, 2009.

  1. macrumors regular

    BORIStheBLADE

    Joined:
    Jun 15, 2008
    #1
    So I downloaded the latest ATVcloner which is a great app I might add and used it accordingly with the original Atv HD.
    Took those .DMG files and put them on a new SATA HD with ATVcloner.

    This is the rest of the material I bought locally. The adapter isnt the same brand as people were using, but it looks like it was rebadged.
    Someone in the Handbrake forums was able to get it going with this bridge.

    http://www.newegg.com/Product/Product.aspx?Item=N82E16812119245

    http://www.newegg.com/Product/Product.aspx?Item=N82E16812186032&cm_re=syba-_-12-186-032-_-Product


    I don't have the crossed cable, but I wanted to get this going by mounting the bridge directly to the Atv board. It seems that all the working bridges have worked that way.

    No matter what configuration I have this bridge the HD won't start up. I have flip the switches and the bridge will only have the power light lit on one way so it won't work if I flip it 180.

    I plugged the HD into another computers power cable just to see if it turns on and it does. So what could keep this from turning on?

    thanks
     
  2. thread starter macrumors regular

    BORIStheBLADE

    Joined:
    Jun 15, 2008
    #2
    Does anyone know how I can check to see if my new HD was setup right?
     
  3. macrumors 68020

    Joined:
    Mar 27, 2003
    #3
    what exactly did atvCloner output for you're drive layout ? If you have the drive out, you can find out by clicking on "Show Partitions" once you have selected the drive you cloned after you attach it to your mac.

    Specifically I want to see if the index 4 partition is actually named Media (in fact, once you attach that drive to you're mac both the boot and media partitions should mount).

    *if* in fact you got a valid Media partition, then I will wager it is you're bridge.

    In my head I am concerned if you got the:

    newfs_hfs: /dev/rdisk2s4: partition size not a multiple of 4K. error

    Issue during cloning, In which case you would not get a valid media partition.

    Edit: If this is the case, and you did not do it the first time, re prepare the drive but check the "Large Drive Formatting" checkbox which has worked around this issue.

    I describe it in some detail here for a drive I had issues with:
    http://dynaflashtech.net/2009/08/18/atv-drive-problem-children/
     
  4. thread starter macrumors regular

    BORIStheBLADE

    Joined:
    Jun 15, 2008
    #4
    ATVclone output a

    boot.dmg
    efi.dmg
    recovery.dmg

    When I mount the new drive after I put the Atv files on it I get two drives on my desktop.

    Media
    Osboot

    When I scan it with ATVcloner it says this

    0: GUID_partition_scheme *1.0 TB disk1
    1: EFI 35.7 MB disk1s1
    2: Apple_Recovery 419.4 MB disk1s2
    3: Apple_HFS OSBoot 943.7 MB disk1s3
    4: Apple_HFS Media 998.5 GB disk1s4

    I hope the last bit helps with your question about the error. I don't know if I looked in the right place.

    mike
     
  5. macrumors 68020

    Joined:
    Mar 27, 2003
    #5
    yep, that should be fine. I am betting on your pata to sata bridge being the culprit. I have never seen the bridge you link to working. Though that doesn't necessarily mean it won't. But it would definitely be my bet.
     
  6. thread starter macrumors regular

    BORIStheBLADE

    Joined:
    Jun 15, 2008
    #6
    Ya I think it is too. I found four different ones locally and wanted to try them out because I was having trouble finding a place that had the ones you guys were using in stock.

    I ended up ordering the Advantech one in this thread. It should be here in a couple of days.

    http://forums.macrumors.com/showthread.php?t=683178&page=2
     
  7. macrumors 68020

    Joined:
    Mar 27, 2003
    #7
    Good luck mike. let me know how it works out. 1 TB of atv goodness doesn't suck. ;)
     
  8. thread starter macrumors regular

    BORIStheBLADE

    Joined:
    Jun 15, 2008
    #8
    Thanks, the worst part is waiting for parts in the mail. I'm sure you can agree.
     

Share This Page