ATV3 killing home sharing?

Discussion in 'Apple TV and Home Theater' started by A2DY, Apr 29, 2012.

  1. macrumors member

    Feb 16, 2011
    Hi all

    I've had atv3 for about a month and all was working perfectly.

    Today I had to restore my laptop to factory due to an issue with it. I reinstalled iTunes added all my content etc but now when I try to stream to the ATV using home sharing after 5 mins or so the picture is lost and says I don't have home sharing turned on. iTunes still says its on but none of my other devices (iPhone and iPad) can connect either?

    I then have to stop home sharing and start again and all will show again and I can play on my iPad using shared videos fine for as long as I have tested (45 mins) but as soon as ATV connects home sharing is stopped again after about 5 mins.

    I have read people having issues with the new iTunes update but can't see how it could be that if I can stream from iTunes to my iPad fine. It's only when ATV tries it stops working. I have tried resetting the ATV back up from scratch but still does it.

    Does any only have any ideas?
  2. macrumors newbie

    Oct 7, 2011
    Hey my ATV has been working perfectly up until last night when it just kept cutting out through a movie and saying loading iTunes library, then was going on about the home sharing. I had to turn the power off to the ATV a few times just to get it to log on to the home sharing. Then did the same Tonight also.:eek:
  3. thread starter macrumors member

    Feb 16, 2011
    Thanks for the reply.

    I have tried rebooting and resetting and didn't get me anywhere.

    I have now also tried uninstalling iTunes and installed iTunes 10.5 but that didn't make any difference.
    Then I have tried "repairing" all apple programs on my system (win 7) by going to control panel, uninstall and selecting repair.
    Now I have managed to watch a show for 40 minutes and it hasn't dropped off yet. Fingers crossed that has fixed it....

    However I still have an issue of when I go to "shared" on my iPads video and look to tv programmes I have two seasons of a show that appear twice and it is missing two other programmes altogether!
  4. macrumors newbie

    Oct 7, 2011
    Might have to try that, tonight it was just showing loading then managed to watch a programme after rebooting three times :confused: I'll have a mess around with it tomorrow on my day off. Seems strange how it hasn't happened once since I got it and now it's every time.
  5. macrumors 6502


    Feb 23, 2008
    QLD, Australia
    Hopefully with this new update, all our Home Sharing "cut out" issues will be solved !!

    Heres hoping..

  6. macrumors 65816

    Oct 8, 2007
  7. macrumors 6502a

    Sep 20, 2005
    Southeast of Baltimore, USA
    When I updated my router firmware and restarted it, the issue stopped for me.
  8. macrumors regular

    May 17, 2011
    I resolved my cut-out issues by removing the home sharing off everything except my Itunes and ATV's.

    My issues then went away.

    This stinks as you can't use the Apple Remote App, but wasn't a big deal. You can train your IR remotes.

Share This Page