Audio in Final Cut Pro X mono, when exported only coming out on the right?

Discussion in 'Digital Video' started by Summersify, Apr 7, 2012.

  1. macrumors member

    Joined:
    Oct 29, 2011
    Location:
    UK
    #1
    Hi,

    In Final Cut Pro X, when I put together a video (the video being from my iPhone) the audio sounds perfectly centred, but when I export it it only plays out of the right speaker.
    The strangest part is I put some sound effects on the video, and they happily play centred. How is that possible? I've made sure the audio for the video is mono, and I've also tested it with my camcorder, but when it exported it only played out of the LEFT speaker this time!

    Any help will be greatly appreciated.
    Thanks, Jack. :)
     
  2. macrumors 6502

    Joined:
    Nov 28, 2011
    Location:
    Stuttgart, Germany
    #2
    I remember having had a similar problem, but I don't know how I fixed it in the end. I kind of am convinced that it disappeared when I exported into ProRes codec, not H.264...? That would be really weird though, and I can't really reproduce it.

    However, there is one thing you can check: If you select the clip (audio or video) that you are talking about in FCPX and open the inspector (Command-4), you can choose the tab "Audio". In this tab, you will see an option for "Pan-Mode" (losely translated, my version is German), right below the volume adjustment. Try to choose the appropriate mode (default is "None", but you can simply pick "Stereo l/r" and determine at which position left/right your mono sound is supposed to be.

    Maybe that helps?
     
  3. macrumors 6502a

    Joined:
    Jun 6, 2011
    #3
    Right is wrong. It should come out of your left speaker. Did you try to change you mono to dual mono?
     
  4. thread starter macrumors member

    Joined:
    Oct 29, 2011
    Location:
    UK
    #4
    The only thing that you suggested I do that worked it change the codec. Thanks for your help, but it's incredibly annoying that I can't export using h.264 then...
     
  5. macrumors 6502

    Joined:
    Nov 28, 2011
    Location:
    Stuttgart, Germany
    #5
    That really is surprising, I could hardly believe when it worked for me, too! You can use Compressor to make H.264 movies, it will be better quality in addition! :)
     
  6. macrumors 6502

    Joined:
    Nov 28, 2011
    Location:
    Stuttgart, Germany
    #6
    If you are still wondering: Final Cut just got an update today and on this webpage, Apple states that the new version "Assigns default audio channel setting for new projects to stereo."

    Maybe that (or something else not mentioned) actually solves your problem? I haven't tried it myself though.
     
  7. macrumors 68020

    Joined:
    Jun 26, 2002
    #7
    audio is a beast when it comes to odd sources.
    Ive had problems in the past with Avid accepting oddities such as phone tap, security feeds and off the shelf cameras.
    I guess if it doesnt have AES/EBU it thinks its mono :p
    In the past I would export the audio alone and see if the anomaly is related to the video codec.
    Export to AIF or WAVE or whatever you can and check if its fine.
    You can always try and import and add as Connected Clip and try again with a new Project (delete original audio of course).
    I know this sounds ridiculous but thats how it goes in this field ;)
    Thus why most of my audio ends up in ProTools first before finishing.
     

Share This Page