Auto Align in Finder

Discussion in 'OS X Mountain Lion (10.8)' started by medavidcook, May 30, 2013.

  1. medavidcook
    Expand Collapse
    macrumors member

    medavidcook

    Joined:
    Feb 16, 2013
    Location:
    Cardiff, Wales
    #1
    Hello,

    I am using Mountain Lion OS.

    My problem is when i create a new file/folder in finder it aligns where cursor is, is there a way to make it align with other files and to go in a-z order.

    As i have to change order then change back to name for it to work every time.

    Hope this makes sense

    thanks
     
  2. justperry
    Expand Collapse
    macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #2
    Go to Menu>View>Show View Options>Sort By .... Anything you like.
     

    Attached Files:

  3. medavidcook
    Expand Collapse
    thread starter macrumors member

    medavidcook

    Joined:
    Feb 16, 2013
    Location:
    Cardiff, Wales
    #3
    Excellent thank you.

    I was looking at that in the finder window, but not there didnt think of the desktop option lol

    Thanks again
     
  4. justperry
    Expand Collapse
    macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #4
    :D
    No worries.
     
  5. medavidcook
    Expand Collapse
    thread starter macrumors member

    medavidcook

    Joined:
    Feb 16, 2013
    Location:
    Cardiff, Wales
    #5
    Hello.

    I thought I sorted this with the above fix, however for some reason its still not auto aligning, the above is showing on my site. but when i look at the sort icon in finder window its always set to none so need to change that.

    Is there anyway to make it always sort by name and snap to grid.
    Thanks
     
  6. justperry
    Expand Collapse
    macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #6
    You mean you can't change it?

    If so I want you to do the following, go to your Home Folder>Library>Preferences, I want you to tell me what the permissions are on that Folder, click get "Info for that".

    Command-I will give you "Get Info", you should have Read and Write Access.
     
  7. medavidcook
    Expand Collapse
    thread starter macrumors member

    medavidcook

    Joined:
    Feb 16, 2013
    Location:
    Cardiff, Wales
    #7
    Hey

    I have changed the section to snap to grid as per post 2. however when i create a new file it doesnt snap to grid or go alphabetically i have to change that myself.

    I have checked and I have read and write access.

    thanks
     
  8. justperry
    Expand Collapse
    macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #8
    I just tried in a different clean User Account, I think you need to set it to sort by name, I did it there and it automatically sorted by name AND snapped to grid.

    If that does not work I am out of ideas, except, try in a clean user account, if it works well there and not in your normal account the normal account has this problem, not system wide.
     
  9. medavidcook
    Expand Collapse
    thread starter macrumors member

    medavidcook

    Joined:
    Feb 16, 2013
    Location:
    Cardiff, Wales
    #9
    hey

    yeh i have tried it and it works in new account not old. so looks like i need to create a new account.
     
  10. justperry
    Expand Collapse
    macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #10
    You could also try to move the com.apple.finder.plist out of the Preferences folder and relaunch finder, be aware that all preferences are reset.
     
  11. medavidcook
    Expand Collapse
    thread starter macrumors member

    medavidcook

    Joined:
    Feb 16, 2013
    Location:
    Cardiff, Wales
    #11
    Hey

    I am on in the preferences folder, and cant locate the file you are talking about. I have also typed the name into general search and looked on whole mac but nothing showing.

    any ideas.
     
  12. Small White Car
    Expand Collapse
    macrumors G4

    Small White Car

    Joined:
    Aug 29, 2006
    Location:
    Washington DC
    #12
    Are you aware there is a separate setting for Finder than there is for Desktop?

    Click Desktop - Hit Command J - Make Changes

    vs

    Click in a Finder Window - Hit Command J - Make Change and click "Apply to All" button


    Are you perhaps changing one without changing the other?
     
  13. medavidcook, Jun 7, 2013
    Last edited: Jun 7, 2013

    medavidcook
    Expand Collapse
    thread starter macrumors member

    medavidcook

    Joined:
    Feb 16, 2013
    Location:
    Cardiff, Wales
    #13
    There is no apply to all button.

    Desktop is 1st one and the finder window second.

    hope this clarifies
     

    Attached Files:

  14. Small White Car
    Expand Collapse
    macrumors G4

    Small White Car

    Joined:
    Aug 29, 2006
    Location:
    Washington DC
    #14
    Well, 'Use as Default' then. Looks like I mis-remembered what it's called but that's the button.
     
  15. justperry
    Expand Collapse
    macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #15
    Tip: If you reply to me click on the quote button, if you do so I can see in my Notifications on MR.

    You probably look in the wrong Library Folder.
    Just click "Go">"Go to Folder…" in Finder, the type "/Users/****/Library/Preferences/" without the quotes, **** is your User name or Home Folders name.

    ----------

    And, you should use "Sort by Name"
     

Share This Page