Autocorrect not work in Mail (but is fine everywhere else!)

Discussion in 'OS X Mountain Lion (10.8)' started by timotay89, Jan 19, 2013.

  1. macrumors regular

    Joined:
    Jul 20, 2011
    #1
    Title says it all. The autocorrect feature does not work in Mac Mail. It's selected to correct as I type in the mail preferences. Autocorrect works fine in other apps (like text edit). In mail it just underlines it in red and nothing else.

    It's a new 13 inch MBP (regular display).

    I have reset the parameters when restarting the computer. I have also tried multiple settings in mail (and system wide) to fix this.

    It's not my computer, so I don't want to have to reinstall Mountain Lion or have to start over with the mail app (unless it's very, very easy to do so, including not having to recreate all rules and smart folders).

    Any help would be greatly appreciated.
     
  2. macrumors newbie

    Joined:
    Sep 28, 2012
    #2
    Same Probz

    Same thing happens in my mail. Any help would be appreciated
     
  3. macrumors 6502

    msjones

    Joined:
    Oct 18, 2007
    Location:
    Nottinghamshire, UK
    #3
    Do you have it set to "Never" under preferences in Mail? Take a look at the screenshot below:

    [​IMG]
     
  4. thread starter macrumors regular

    Joined:
    Jul 20, 2011
    #4
    No, it's set to "As I Type" but it doesn't correct it as I type.

    This is for my parents new MBP. I put the same setting on mine and it seems to work fine and correct it as I go.
     
  5. macrumors newbie

    CarisaC

    Joined:
    Feb 20, 2013
    Location:
    North Carolina
    #5
    I finally got my mac mail to autocorrect as I type. To do it, reply to any message in your inbox. Then go to Edit/Spelling and Grammar and click on "Correct Spelling Automatically." If you don't have a message open, this option will be grayed out. But once you've checked this option for one message, it'll autocorrect in every message you send.
     

Share This Page