Autocorrect

Discussion in 'Mac OS X Lion (10.7)' started by DJLC, Aug 2, 2011.

  1. macrumors 6502

    DJLC

    Joined:
    Jul 17, 2005
    Location:
    Mooresville, NC
    #1
    So I just fired up Coda for the first time since installing Lion. All is well, except it auto corrects two dashes, replacing them with an actual hyphen. This is usually desirable, but obviously not in Coda. Is there a way to disable autocorrect in Coda only as opposed to toggling it on and off for the entire system every time I need to do web development?
     
  2. macrumors 6502a

    Joined:
    Feb 26, 2011
    Location:
    Las Vegas, NV
    #2
    Wirelessly posted (iPhone 4: Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_3_5 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8L1 Safari/6533.18.5)

    You could always not accept the autocorrect.
     
  3. thread starter macrumors 6502

    DJLC

    Joined:
    Jul 17, 2005
    Location:
    Mooresville, NC
    #3
    There doesn't seem to be a way to deny the autocorrect as there is in other apps. Right-clicking doesn't allow me to reverse it, and replacing it only makes it autocorrect again.
     
  4. macrumors 68000

    paulsalter

    Joined:
    Aug 10, 2008
    Location:
    UK
    #4
    try this

    go to the edit menu and then down to spelling and grammar

    can you change the correct spelling automatically to check spelling while typing

    this should remove the autocorrect for this one app and put it back to underlining the things it thinks are mistakes
     
  5. macrumors member

    nervouk

    Joined:
    Jul 13, 2002
    Location:
    tokyo
    #5
    This is driving me a bit nuts too. When typing three periods into Coda it auto-changes it to the ellipsis character. Not great for writing code.

    I notice it happens to text in some apps (Coda, TextEdit, VoodooPad) but not others (TextWrangler, Scrivener). Something to do with text encoding in each?

    I looked at Edit > Special Characters and unchecked 'punctuation' but that didn't solve it either. I'm sure there's something really simple and obvious I haven't considered yet...
     
  6. macrumors newbie

    Joined:
    Nov 8, 2011
    #6
    It looks like these substitutions can be disabled via System Preferences > Language & Text > Text tab > Use symbol and text substitution.

    You'll need to restart Coda after the change for it to take effect.
     

Share This Page