Automator to shut down PowerBook

Discussion in 'Mac Apps and Mac App Store' started by GoCubsGo, Apr 27, 2006.

  1. GoCubsGo macrumors Nehalem


    Feb 19, 2005
    I run 10.4.5 and I have my eye tv recording a couple of shows throughout the day. Each morning I come in and schedule the computer to sleep at one time, then at around 8pm the computer wakes to record and I come in and schedule the next sleep for say 11pm. The biggest problem is that I have to schedule the powerbook to go to sleep twice a day. My powerbook is in clamshell mode and there is no reason why after the show is recorded it shouldn't just go to sleep---but it doesn't so I was thinking there must be some script that I can write to tell my computer to sleep at say 2:30 and 12am. Does anyone know how I could do this with Automator?

    I know it's a long shot--but I figured I'd ask.
    PS I mean sleep not shut down.
  2. jsw Moderator emeritus


    Mar 16, 2004
    Andover, MA
    jessica., I'm sure it's possible to do it, if not with Automator then with AppleScript and/or Terminal (see here).

    However, isn't it sufficient to just set the sleep times in System Preferences...->Energy Saver so the computer sleeps when not in use?

    Edit: see below for the Automator action. I don't use Automator, so I'm not sure how to schedule the action, but this'll sleep the computer when run:

    Edit: or I guess open up Applications->AppleScript->Script Editor, enter the script text..., save it as a script, then run it as an iCal alarm event.

    Edit: Verified. Open up Applications->AppleScript->Script Editor, type in "tell application "Finder" to sleep":[​IMG]

    save as a script:

    then set iCal to run it:
  3. GoCubsGo thread starter macrumors Nehalem


    Feb 19, 2005
    Wow I am going to try that. To address your point about why not allowing the powerbook to just sleep after no activity for a period of time, for some reason after I went to 10.4.2 my powerbook never goes to sleep while in clamshell mode. I am not sure why. I turn my mouse off, my BT keyboard is still active, but I can't see that being an issue. So I'm not sure. It was just easier to ignore it for some reason.
    Thank you for your help. I am going to try this out.

Share This Page