Avoiding Gapless Playback

Discussion in 'macOS' started by skunk, Nov 14, 2006.

  1. skunk macrumors G4

    skunk

    Joined:
    Jun 29, 2002
    Location:
    Republic of Ukistan
    #1
    I don't like "gapless playback": if a playlist has Maria Callas followed by Captain Beefheart, I need those two seconds in between. Is it possible to disable it, or do I have to downgrade (again) to v6?
     
  2. PYR0M310N macrumors 6502a

    PYR0M310N

    Joined:
    Aug 29, 2006
    #2
    highlight both of the songs and right click/ ctrl click and go into get info. then at the bottom there is the gapless playback option, and this should be set to no.

    Hope this is what you were looking for.
     
  3. Counterfit macrumors G3

    Counterfit

    Joined:
    Aug 20, 2003
    Location:
    sitting on your shoulder
    #3
    There shouldn't be any gapless playback unless you have it set in the song's options. Check to see if you have crossfade turned on. Even if it's off though, you won't get 2 full seconds, or even one.
     
  4. skunk thread starter macrumors G4

    skunk

    Joined:
    Jun 29, 2002
    Location:
    Republic of Ukistan
    #4
    Doesn't make any difference, as far as I can see. Still no gap. I can't see what that checkbox is for at all. It's checked by default, and every song still runs straight into the next. No gap. Why the hell have they messed this up? I'd actually rather have four or five seconds' grace before the next song.
     
  5. gloss macrumors 601

    gloss

    Joined:
    May 9, 2006
    Location:
    around/about
    #5
    Was it ever that long? My iPod has always had a brief, millisecond long silence between songs. Short enough to just break the flow.
     
  6. skunk thread starter macrumors G4

    skunk

    Joined:
    Jun 29, 2002
    Location:
    Republic of Ukistan
    #6
    It used to follow the import preferences, i.e. a default value of 2 secs. If I could just add two seconds onto the end of each track, that would do it, but my attempts to do that don't stick (you can shorten the song, but you cannot lengthen it), and anyway that's a hell of a process for each song, unless there's a script to do it.
     
  7. danny_w macrumors 601

    Joined:
    Mar 8, 2005
    Location:
    Austin, TX
    #7
    I asked this very same question several times in the past, and no fix was ever put forward. I have never used gapless, I have not upgraded iTunes to the 'gapless' version, crossfade is disabled, and yet both my iTunes and my iPod (Nano) run songs together! It is very annoying, and I never remember having this with other mp3 players. Both my iPod and iTunes have been relegated to mostly unused mainly because of this.
     
  8. skunk thread starter macrumors G4

    skunk

    Joined:
    Jun 29, 2002
    Location:
    Republic of Ukistan
    #8
    I agree, and to make it worse, I've just blown a wad on two sets of speakers and can't listen to my CDs as recorded. :mad:

    Any script kiddies out there got any bright ideas?
     
  9. apfhex macrumors 68030

    apfhex

    Joined:
    Aug 8, 2006
    Location:
    Northern California
    #9
    Durrr, iTunes 7 adds gapless playback to all tracks, all the time. True gapless has got to be the longest requested feature, since 1.0. I know I've been waiting for it for that long. It would be nice if they allowed you to set an option to add a gap between songs though.

    From iTunes Help...
     
  10. danny_w macrumors 601

    Joined:
    Mar 8, 2005
    Location:
    Austin, TX
    #10
    I use iTunes 6, and have never upgraded to 7 for that very reason. Now I know that I never will.
     

Share This Page