Azureus Problems

Discussion in 'Mac Apps and Mac App Store' started by 66217, Nov 24, 2006.

  1. 66217 Guest

    Jan 30, 2006
    By doing research it seems that I have NAT problems, but I am so a newbie in this kind of things that I don't know what to do.

    1: How do I know if I have a router?:eek: (I have wireless internet. The thing that send the signal is directly connected to the internet cable.)

    2: Sometimes I have download speeds of 58 kB/s. But most of the time I am at 3-6 kB/s. Is it possible this is a NAT problem? (I always have the yellow smiley.)

    I don't have any firewall, nor any other programs that can be interfering with Azureus. Ane help would be appreciated:)

  2. RedTomato macrumors 68040


    Mar 4, 2005
    .. London ..
    You should really have firewall on.

    There are two places to set it up.

    1. On your mac, go to Preferences / Sharing / Firewall. Turn it on.

    1.1. Click New.. / Other, give it a name 'Azureus' and a port number e.g. 50001

    2. Go to Firefox or Safari, and enter your wireless router address (it should have a web address of its own, will be in the manual or type in the wireless router name in Google and look around).

    2.1. Enter password - the default will be in the manual or on the internet.

    2.2. Turn on firewall. (if it isn't already on)

    2.3. Look for a setting called port forwarding or NAT translation or something like that.

    2.4. See if you can add a new rule, called 'Azureus' and set to port 50001, both incoming and outgoing, and set it to the name/network card address of your mac.

    3. Open up Azureus, go into preferences, and set it to listen on port 50001.

    Wait a while, maybe 15mins, and you should get a green NAT.

    Basically what you've done is:

    - tell the router to block most things/ports that aren't web traffic or email, but to accept traffic on port 50001,

    - tell the router to send this incoming traffic on port 50001 to your mac, not to some other computer on your network.

    - tell your mac to block most things that aren't web traffic or email but to accept a connection on port 50001

    - tell Azerus to listen out on port 5001.

    Hope that helps get you started. Yes you need to read manuals and try to understand the Azureus help files on what NAT means.

    It's not very clear cos there's so many different models of routers and firewalls out there, so you need to use your brain to make it work.

    xoxo Tomato.

    By the way, I use P2P to share video files of us signing to each other with my deaf mates. Faster than emailing them. That's a legitimate use. So there.
  3. Eraserhead macrumors G4


    Nov 3, 2005
    Definitely switch on the firewall, and as it's wireless you do have a router ;) .
  4. 66217 thread starter Guest

    Jan 30, 2006
    I've made all the previous steps. But I still have the yellow smiley.

    Any other problems I could have?


  5. Toby Goodbar macrumors 6502

    Sep 8, 2006
    get back to your router settings from the browser and look for upnp mapping and turn it on. on my netgear router's menu on the sidebar at the very bottom is says "upnP" just click on that (if you have a netgear router) and you should have a check box to click.

    then report back.
  6. 66217 thread starter Guest

    Jan 30, 2006
    sry for not replying yesterday.....

    I don't seem to have this option (I'm on a Motorola SBG900). I do saw the options to put an static ip, and to enable/disable nat.

    Should I move any of these options? Right now I am on a dynamic ip. but as far as I know, every time I check my ip it is always the same.

    Thanks for the help,

  7. Nermal Moderator


    Staff Member

    Dec 7, 2002
    New Zealand
    Not necessarily, for example I have my AirPort Extreme configured as a bridge.
  8. Toby Goodbar macrumors 6502

    Sep 8, 2006
    i would probly enable nat but your router is also your modem. you have an all-in-one system so i'm not exactly sure. check your manual and see if you caan find info there about the upnp settings. you might check under port forwarding too.

Share This Page