Bad Power Supply? MDD G4 trips APC overload circuit...

Discussion in 'PowerPC Macs' started by super_kev, Aug 30, 2009.

  1. macrumors 6502

    Joined:
    Jan 12, 2005
    #1
    I recently fired up a old MDD G4 at work, and after 5 seconds or so, the APC unit that it was connected to started warning that there was a current overload, and killed the power port. I plugged in another computer to make sure that it wasn't a general overload, and it ran fine, so it's a problem with the MDD. The power supply area smelled a little different, and it was hot. The system powers on completely (fans, hard drive, etc.), but it just trips the overload circuit by drawing too much power. Is there a way to take apart the PSU and see what's going on?
     
  2. macrumors G4

    Joined:
    May 6, 2008
    #2
    Do you have access to a Digital Multimeter, or preferably an Electronics Test Bench of some sort, and knowledge of circuits?

    I figured I should ask. ;)
     
  3. thread starter macrumors 6502

    Joined:
    Jan 12, 2005
    #3
    Sure, I've done my fair share of electronics tinkering (no test bench though... not there yet). I thought I'd ask around before I opened up the PSU, as I don't really know what I'm looking for once I'm inside. Post up. :)
     
  4. macrumors G4

    Joined:
    May 6, 2008
    #4
    NP.

    OK, this is going to limit what can be accomplished, but pull the PSU, and open it. Let's start with visual inspection, and see if there's anything blatantly obvious. (I'm really nervous about having you power up the PSU off the wall, to attempt a DMM reading or two).

    1. Check for smells. Hard to explain it online, but it can give you a big clue.
    2. Look closely at the capacitors. At this age, they tend to go bad, and leak. Look for a greenish to greenish-brown liquid on the PCB. (DON"T TOUCH THE PINS, as you could get nailed)!

    Let me know what you find. :)
     
  5. thread starter macrumors 6502

    Joined:
    Jan 12, 2005
    #5
    I'll tell you right now that something didn't smell right. Not super obvious, but when I opened the case and got close to the PSU there was an overloaded smell. I can't pull it now, but I'll try tonight and see what I find.
     
  6. macrumors G4

    Joined:
    May 6, 2008
    #6
    That's expected. The question is, is it caps, transformer windings (got too hot, and burnt off the varnish = short), or transistors (Voltage Regs). Or some combination. :eek:

    You might want to search online for a schematic of the PSU, as it will help. Not absolutely necessary, but FAR easier than having to figure it out, and sketch it for reference as you go.

    Also, pics would help (if possible). :)

    Given the fact it's a Mac, rebuilding it might be the way to go. I'll take a quick check (macpalace.com), and see if I can get an idea of the cost for a replacement unit (without the exact P/N). ;)

    But you would need a good soldering iron to do this (even for diagnostics), as the cheap ones not only end up burning you, but the PCB as well (lifted traces, and/or scorch marks on the FR material).

    Good luck, and let me know what you find out. :)

    EDIT:
    Found 2 candidates:
    Power Supply, w/ PFC (661-2725)

    Power Supply, with PFC (661-2816)

    Basically $220 & $280USD respectively, so not exactly inexpensive. Perhaps a parts machine would do (eBay perhaps), if you can find one, that has a good PSU in it. So a rebuild would be a possibility, if you've the time.
     
  7. thread starter macrumors 6502

    Joined:
    Jan 12, 2005
    #7
    Alrighty bud, been awhile, been quite busy. I brought the G4 home tonight to rip it apart.

    First off, the computer has been sitting unplugged since my last post. I pulled the CUDA battery and tested it (good voltage), then waited 10 min, put the bat. back in, pressed the PSU reset button for a few seconds, then plugged in the power cord and tried the power on the G4.

    The power button glowed when I pushed it, and I heard a faint "zz" for a split second, like something was shorting out. The red motherboard lights came on during that time, and then power light did it's pretty little fade to black and nothing else happened. I tried to press it again, but it seems as though it has a "cool-down" period, and I had to wait a few more seconds before I could get the faint shorting out/zz/click sound and the lights/etc. It happened even when the CD & HD were unplugged.

    I grabbed a service manual PDF, did part of the PSU verification tests (got +25VDC on pin 14, +5V "trickle" on pin 1) but then when it came to the third step where I was supposed to power the machine on, it told me to replace the PSU since it didn't power on.

    I pulled the PSU, and it's a AcBel API1PC36 unit. I've included a picture. No schematics on the 'net that I can find. What's next?
     

    Attached Files:

  8. macrumors G4

    Joined:
    May 6, 2008
    #8
    OK, the unit is the 661-2816 (Apple's P/N). Here's a less expensive source (used w/ 90 day warranty), if you're interested.

    Otherwise, you could try to get a schematic from the company that made it. If they won't, you'll have to trace it out, and test. Time consuming, but possible. But given the lack of a bench, it could prove really tough if you need more than a DMM.

    Any burnt areas, or odd smells? (could offer a starting point).

    EDIT: I found a generic 200W ATX PSU schematic. It could get you started. ;)
     
  9. thread starter macrumors 6502

    Joined:
    Jan 12, 2005
    #9
    Good grief; might as well buy a used MDD. ;) No burnt smells from the guts of the PSU...

    I'll contact AcBel and see what they say, then go from there.
     
  10. macrumors G4

    Joined:
    May 6, 2008
    #10
    I found a schematic that could get you started if AcBel is a dead end (above post as an edit). But they don't seem to make that family any longer, and should be more willing to provide it to you. I'll cross my fingers, and hope they understand the request, as English won't be their first language afterall... ;)

    There's also paid schematic sources as well, but as a last resort.

    A new one is expensive for what it is, no doubt. Repair would be much less expensive. Its just really time consuming with out the schematics. Trust me, been there, done that a few times more than I'd like to remember. A royal PITA. At least it's not the most complicated circuit you could have run into. :p
     
  11. thread starter macrumors 6502

    Joined:
    Jan 12, 2005
    #11
    Ok well no response from AcBel so far. I just sent another email. In the meantime, I picked up a second MDD G4 that works. So I have one working PSU and one dead one, so I can map things out and compare voltages if I need to. I'll be using both computers, so I can't just swap out the dead PSU.

    I looked at the circuit board closer and everything is nicely tagged ("R32" next to a resistor, "W8" next to a jumper wire, "VR1" next to a voltage regulator, etc.) so I guess I will start mapping things out. Would it be bad for me to remove the silicone/thermal "glue" that surrounds some of the parts and circuit board? Have any suggestions for some good PCB layout programs to make this whole thing easier?
     
  12. macrumors G4

    Joined:
    May 6, 2008
    #12
    Leave the glue unless you need to pull it. If that's the case, just make sure you re-glue it once the repairs are completed, and give it enough time to dry.

    As per PCB routing software, yes, but it's for Windows. PCB 123 (freeware). :) Others as well, but they're not free, and the trials are limited as to what you can do, as are the student licenses (limits to board size and part counts).
     
  13. macrumors member

    Joined:
    Oct 23, 2009
    #13
    Hi
    Under their wind-tunnel/leaf-blower noise reduction scheme Apple sent out thousands of replacement MDD PSUs to anyone who paid the £15 packaging/delivery cost.

    There must be lots still on the shelf out there - I've got two that I've never touched....
     
  14. macrumors G4

    Joined:
    May 6, 2008
    #14
    Perhaps you could work something out with super_kev?
    It's certainly much easier than attempting to repair the DOA unit. ;)
     
  15. thread starter macrumors 6502

    Joined:
    Jan 12, 2005
    #15
    I'll check into PCB123.

    PaulD-UK, if you have one that you really want to get rid of, let me know. I'll take it. :D
     
  16. macrumors 6502

    lannister80

    Joined:
    Apr 7, 2009
    Location:
    Chicagoland
    #16
    You could always try an ATX --> MDD conversion.

    I think the only thing that won't work with that kind of conversion is firewire (needs a funny voltage):

    http://www.applefritter.com/node/23857
     
  17. n6ac, Feb 27, 2011
    Last edited: Feb 27, 2011

    macrumors newbie

    Joined:
    Apr 7, 2009
    #17
    super_kev - did you ever find the cause non-starting?

    Hello Super_Kev, My trusty old G4 FW800 also has begun failing to start except after long pause disconnected. I'm wondering if you ever pinned down your cause? Or ever got any info from AcBel ?
    ... Al
     

Share This Page