bash or tcsh which is the default for OSX 10.4.5?

Discussion in 'macOS' started by jazzlover2002, Apr 4, 2006.

  1. jazzlover2002 macrumors newbie

    Mar 8, 2005
    Hi, All,

    I'm trying to follow instructions for installing Ruby and RadRails on my Power Book Ti. The instructions tell me that before I do anything I have to add some folders to my PATH.

    It gives me instructions on how to do this that read as follows:

    create a .bash_login file and enter this line:

    export PATH="/usr/local/bin:/usr/local/sbin:$PATH"

    So I did that, but when I go to execute the file I get a "command not found" error message.

    So at my terminal I typed env and saw this line:


    That would seem to indicate that my shell is tcsh not bash.

    So how do I get bash to become my default shell? Is that possible? Is bash the default shell for OSX 10.4.5 or is tcsh? Why does my terminal load tcsh for my shell?

    I need the path to be modified when I boot up so /usr/local/bin and /usr/local/sbin are checked first before any other folders for Ruby and other components I'm installing. How do I accomplish this?

    Please keep in mind, I'm just now learning Unix so go easy with me. :)

    Thanks for you help.

  2. gekko513 macrumors 603


    Oct 16, 2003
    Either: Applications -> Utilities -> NetInfo Manager
    And change the shell value for your user.

    Or: Terminal -> Preferences
    And change the "Execute this command" to /bin/bash
  3. DNH macrumors member

    Oct 15, 2003
    Halifax, NS, Canada
    2 options

    Well, you've got two options to fix your problem: change shells or modify the .tcshrc file

    If you want to change shells, you can do so by launching the Netinfo Manager in /Applications/Utilities. Once that loads, you can click on users and then your short username. Click the lock to authenticate to make change and replace /bin/tcsh in the shell entry with /bin/bash. Save your changes, logout and back in and you should be all set. I should warn you, though, that messing with the Netinfo Manager can screw things up if you're not careful.

    If you'd rather stick with tcsh, you can add the line below to your .tcshrc file.

    setenv PATH /usr/local/bin:/usr/local/sbin:$PATH

    Either way, it should work (if I remember the syntax correctly). Hope that helps.
  4. janey macrumors 603


    Dec 20, 2002
    sunny los angeles
    hey, just wondering
    was this an upgrade from a previous version of OS X or a clean install? tcsh hasn't been the default shell for a long time now..

    Also, for a quick and dirty rails development platform, check out locomotive - (I mean, I'm just guessing, because like everyone playing around with ruby nowadays seems to be doing it because of rails)

    and, of course, the popular editor for ruby that everyone seems to love is textmate -

    ruby is a very gorgeous language, btw :) have fun playing with it

Share This Page