Belkin USB-ADB woes. (not working right)

Discussion in 'Mac Accessories' started by spinne1, Jan 7, 2006.

  1. spinne1 macrumors 6502a

    spinne1

    Joined:
    Mar 12, 2005
    Location:
    Hermitage, TN USA (near Nashville)
    #1
    I just got a Powermac G4/533 and I love it. However, I refuse to use the Apple USB Keyboard that goes with it. Sure, it looks nice, but yuck! Anyhow, I LOVE my Apple Extended Keyboard II (boo for ugly beige though) and so bought a Belkin USB-ADB adapter off ebay. When it works it is great, but it does not always work. After being on for a while, the little red LED on the front of the Belkin will go off and the keyboard will then be dead until I restart. This will restore power to the Belkin for a little while and then it will go dead again. Anyone have any possible reasons or solutions?

    PS I tried it on both the main USB bus and also a IOGear USB 2.0 PCI card, and both did the same thing.

    Thank you
     
  2. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #2
    Belkin. :(

    It's synonymous with low-quality crap. Have you looked on the Belkin website for a driver update, troubleshooting steps, or something of that ilk?
     
  3. spinne1 thread starter macrumors 6502a

    spinne1

    Joined:
    Mar 12, 2005
    Location:
    Hermitage, TN USA (near Nashville)
    #3
    Yes. Nothing.
     
  4. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #4
    Sorry, don't have any ideas other than buying a new Apple keyboard. While they're not quite like the old Extendies, I'm guessing you have one of those craptastical wee keyboards where all the keys were shortened and squished together. My only advice beyond that is to presevere with a new keyboard, eventually you'll get used to the difference in the keys.
     

Share This Page