best 1920x816 HD resizing for TV with Handbrake

Discussion in 'Apple TV and Home Theater' started by Nord, Jun 26, 2010.

  1. macrumors member

    Joined:
    Apr 28, 2010
    #1
    Hi there ! :)

    I could not find this in the forum, so I dare ask.

    What's the best resizing of an MKV 1920x816 video with Handbrake to be viewed on an Apple TV while keeping the HD format (720p) ?
    I'm confused with all these formats, Handbrake by default gives: 1280x544
    Is that good or bad ? I can't pull up to 1680x720, I guess the Apple TV won't read it, does that mean I have to crop the video's width ? Or is the default 1280x544 better (I don't car if there are black lines if the Apple TV supports it, I'd prefer to keep the whole picture if possible)
    I have no Apple TV yet, but I'm preparing a few videos in the event of purchasing one soon.

    I'm no expert, I just know I need to keep it under 25 fps and under 5000 kbps, but with this cropping stuff, it beats me.

    I any charitable soul could help me there just a bit, I'd appreciate it. :)

    Thanks to all repliers !
     
  2. macrumors 6502a

    Joined:
    Dec 30, 2008
    Location:
    Nottingham, UK
    #2
    It depends what the frame rate of the original file is:-

    Original 1920x816 which is a 2.35:1 aspect ratio so the original would have black bars top and bottom.

    If the frame rate is 24fps or less then encode it at 1280x544 which is still 2.35:1 and will still have black bars top and bottom.

    If the frame rate is greater than 24fps then encode it at 960x408 and again it will have black bars top and bottom.

    Also note that 1280x544 is still 720p because once the extra 88 pixels for the black bar at the top and 88 pixels for the black bar at the bottom are added back on it becomes 1280x720.

    My advice is if the frame rate is 24fps then go with what Handbrake gave you, 1280x544.
     
  3. thread starter macrumors member

    Joined:
    Apr 28, 2010
    #3
    Aaah, I get it, with the black bars, it give a 720.

    Well, thanks a lot for your kind and full response roidy. :)

    I'm a newbie here, is there something I must do to check the thread as "solved" ? Or do I simply rate it or something ? Sorry if it's a trivial thing, I can't seem to find it. :p
     
  4. macrumors 6502a

    Joined:
    Dec 30, 2008
    Location:
    Nottingham, UK
    #4
    No problem, and no theres nothing you need to do to the thread.
     
  5. macrumors regular

    Joined:
    Jan 7, 2004
    #5
    Actually, AppleTV can handle anamorphic HD material. If you really want to maximize your pixels, you can set the actual picture size at 1280x720. Then select the "custom" anamorphic setting. If you also check the box to keep the aspect ratio, then you will have an anamorphic picture size of 1680x720, which will play fine on AppleTV. This will increase your pixels by 33%.
     
  6. thread starter macrumors member

    Joined:
    Apr 28, 2010
    #6
    Always good to know, but thanks, I'll keep it like this. I prefer to see the original size rather than forcing the image to stretch.tog et more pixels. :)
    But hanks for the tip.
     
  7. macrumors regular

    Joined:
    Jan 7, 2004
    #7
    The entire DVD industry disagrees with you, but whatever...
     
  8. macrumors newbie

    Joined:
    Jul 24, 2005
    #8
    Aspect Ratios

    Hi

    I have a similar problem. I am using Handbrake to convert some of my older movies and need to change the aspect ratio to 16:9. They are presently the older smaller screen where I have to manually change the TVs aspect ratio for fullscreen. What do I need to do?

    Thanks
     
  9. macrumors 6502a

    Joined:
    Dec 30, 2008
    Location:
    Nottingham, UK
    #9
    You should really have started a new thread, but here you go.......

    Select custom anamorphic, turn off "keep aspect ratio", make sure width and height are the same as your source(720x576 for PAL DVD or 720x480 for NTSC DVD) and then:-

    If the DVD is PAL(720x576) set PAR width to 64 and PAR height to 45 which should give a display size of 1024x576.

    or

    If the DVD is NTSC(720x480) set PAR width to 96 and PAR height to 81 which should give a display size of 853x480.

    pal.jpg
     
  10. thread starter macrumors member

    Joined:
    Apr 28, 2010
    #10
    Yeah, so it seems... :rolleyes:
    Well, at least I defend the force of my convictions. ;)

    Thanks a bunch for all your answers.
     
  11. macrumors regular

    Joined:
    Jan 7, 2004
    #11
    If the file has already been encoded and all you need to do is change the aspect ratio, you can do that in Subler without having to re-encode.
     
  12. macrumors newbie

    Joined:
    Jul 24, 2005
    #12
    Aspect Ratio

    Thanks much for the post, but I must be doing something wrong. All I am getting is a very thin wide bar in preview.

    What am I doing wrong? Also what is the program someone is refering to Subler?

    Steppenwolf
     
  13. macrumors 6502a

    Joined:
    Dec 30, 2008
    Location:
    Nottingham, UK
    #13
    Haven't a clue what your doing wrong, the settings I posted work perfectly for me for both PAL and NTSC material. Did you copy the setting exactly as I showed in the image.

    Subler:-
    http://code.google.com/p/subler/
     
  14. macrumors regular

    Joined:
    Jan 7, 2004
    #14
    I've seen that behavior before as well. I think it is a bug. I had to quit the program and start over.

    Not sure if Subler will work in your situation but it is pretty handy. Just open the file in Subler and select the Video track. That will open controls for the aspect ratio. Adjust as needed...
     

    Attached Files:

  15. macrumors 6502a

    Joined:
    Dec 30, 2008
    Location:
    Nottingham, UK
    #15
    Steppenwolf323 try the latest nightly version of Handbrake, if your not already.
     
  16. macrumors newbie

    Joined:
    Jul 24, 2005
    #16
    Subler

    TommyLotto - Thanks much, but I keep getting at "Can't mux audio track" error with subler.

    What am I doing wrong?

    Wolf
     
  17. macrumors regular

    Joined:
    Jan 7, 2004
    #17
    Hmmm. Not sure. What type of audio does your file have? Maybe Subler can't handle that type of file.
     

Share This Page