Birthdays in Notification Center

Discussion in 'iOS 6' started by parkm13, Jun 18, 2012.

  1. macrumors regular

    Joined:
    Aug 25, 2010
    #1
    I am running iOS 6, when I logged into my account it began syncing all my friends birthdays to my calendar. This is not a big deal, as i can simply hide that calendar so they will not show up. However hiding the calendar will not remove the birthdays from the notification center. Having them there is very annoying and I would love to find out how to remove, only the events that came with Facebook, from notification center. Any help would be great!
     
  2. macrumors 603

    Tyler23

    Joined:
    Dec 2, 2010
    Location:
    Atlanta, GA
    #2
    Under Settings, go to Facebook settings. There you can toggle on/off whether Facebook integrates with calendar and contacts. You'll want to disable calendar integration there.
     
  3. thread starter macrumors regular

    Joined:
    Aug 25, 2010
    #3
    I have that turned off, still stays in the calendar. I think that is just stopping it from adding any new events.
     
  4. macrumors 603

    Tyler23

    Joined:
    Dec 2, 2010
    Location:
    Atlanta, GA
    #4
    Well it may be contacts then? All I know is I had both enabled at first and it added all my FB friends' birthdays to my calendar and NC. After disabling both, this problem has been no more. Hopefully that will work for you, otherwise maybe you need to reinstall?
     
  5. macrumors member

    Joined:
    Apr 28, 2010
    #5
    I had this problem also, especially annoying if you have a lot of Facebook friends - It seems that Facebook adds a Birthday to each of your contacts where it can. Toggling off 'Contacts' under Settings > General > Facebook as mentioned should fix this.
     
  6. macrumors regular

    Joined:
    Dec 16, 2011
    Location:
    Germany
    #6
    Yeah, birthdays are in the contacts. I think there is rather an option missing to control what calendars are shown in the Notification Center, that's not a particular Facebook issue.
     
  7. thread starter macrumors regular

    Joined:
    Aug 25, 2010
    #7
    I turned off the contacts for Facebook and it didn't do anything
     
  8. macrumors 6502

    Joined:
    Aug 30, 2011
    Location:
    New Zealand
    #8
    it will be reading from your contacts from iCloud, or on the phone
    not Facebook


    iv got my uncles birthday in notification center, i think its a nice touch, a handy reminder
     
  9. macrumors 6502

    Joined:
    Jun 17, 2009
    #9
    I had that problem and I turned Contacts and Calendar for Facebook both off then enabled Calendar again so that it only gave me birthdays of people in my phone contacts list.
     
  10. thread starter macrumors regular

    Joined:
    Aug 25, 2010
    #10
    I agree that it is nice, but there needs to be a limit. I don't like seeing 3 birthdays a day of people I only know a little bit and do not really care about.
     
  11. macrumors 68000

    Joined:
    Apr 13, 2010
    Location:
    Into the lungs of Hell
  12. macrumors regular

    soundsgoodtome

    Joined:
    Jun 8, 2007
    Location:
    Los Angeles
    #12
    Correct. I'm running iOS 5.x (which has no Facebook integration), and I have the same issue: unwanted birthdays in Notification Center.

    While FB integration may in fact increase the number of birthdays that are available for display, that's not really the issue, here. The issue is that there seems to be no way to completely disable the display of birthdays in Notification Center.

    Frustrating.
     
  13. macrumors regular

    Joined:
    Jun 12, 2012
    Location:
    Boulder,CO
    #13
    All you need to do is go into the calendar app, click on the calendar button (top left corner) and deselect the one at the bottom called birthdays!! :)
     
  14. macrumors regular

    soundsgoodtome

    Joined:
    Jun 8, 2007
    Location:
    Los Angeles
    #14
    Please reread and understand the issue being discussed. We're talking about Notification Center.
     
  15. macrumors 68000

    Sylon

    Joined:
    Feb 26, 2012
    Location:
    Michigan/Ohio, USA
    #15

    That doesn't work.


    I'm having the issue as well. I made the mistake of syncing my FB friends and noticed how crazy it went. I then turned FB syncing off for contacts and calendars. I then turned off the birthday calendar in the calendar section. They are still appearing in NC.

    Hopefully GM will fix this, or there will be a lot of pissed off people when iOS 6 drops.
     
  16. macrumors regular

    Joined:
    Jun 8, 2010
    #16
    Worked for me.
     
  17. macrumors newbie

    Joined:
    Sep 19, 2012
    #17
    Got it! Go to the Facebook app. Tap Account Settings. Then tap Notifications and uncheck Events.

    ----------

    Ok. Maybe not.
     
  18. macrumors newbie

    Joined:
    Sep 19, 2012
    #18
    Ok. Think I finally got it. In the iPhone's settings go to Facebook. Then run off calendar and contacts. Then go into the Facebook app and do what I said above. You can then turn on contacts and calendars again under the iPhone Settings menu.
     
  19. macrumors member

    Joined:
    Jan 29, 2008
    #19
    This worked for a couple minutes and then refreshed and had refilled Notification Center with birthdays.
     
  20. macrumors member

    Joined:
    Sep 12, 2012
    Location:
    Canada
    #20
    I have the same problem but I just let go, it fills my notification center, and I get to be notified from certain people's birthday.
     
  21. macrumors regular

    BanterClaus

    Joined:
    Feb 19, 2011
    Location:
    UK
    #21
    Same problem here. I think i'm just going to not use Facebook contact syncing as this is just silly.
     
  22. macrumors newbie

    Joined:
    Sep 19, 2012
    #22
    You have to uncheck contacts in the Facebook setting AND also press update contacts after that.
     
  23. macrumors 6502

    Joined:
    Dec 22, 2006
    #23
    Thank you! This worked for me as well.

    ----------

    Thank you! This is what worked for me as well.
     
  24. macrumors newbie

    Joined:
    Jun 12, 2011
    #24
    This is what I did and it worked for me:

    Go to: Settings > Facebook > uncheck 'Calendar', 'Contacts'
    Then go to: Calandar > Calendars > uncheck ' Facebook birthdays'
    Then go to Settings > Notifications > Calendar > uncheck to off
    Then go to Settings > Facebook > 'Update Contacts'
    Then, finally: go to Settings > Notifcations > Calendar > check to on

    Be sure to leave 'Calendars' AND 'Contacts' unchecked.
     
  25. macrumors 6502

    Joined:
    Apr 8, 2010
    Location:
    Coventry, UK
    #25
    This worked great for me. I managed to recheck contacts and it didn't come back, although we'll wait and see for whoever has a birthday next.
     

Share This Page