Blue pinwheel javascript cursor?

Discussion in 'Site and Forum Feedback' started by mcdj, Nov 6, 2011.

  1. macrumors 604

    mcdj

    Joined:
    Jul 10, 2007
    Location:
    NYC
    #1
  2. macrumors 68000

    EvanLugh

    Joined:
    Aug 29, 2007
    Location:
    Developer land
    #2
    i believe it depends which browser you're using. For example in chrome, i get the watch. There was an article somewhere about websites setting it for certain browsers. I think safari has always had it, though?
     
  3. macrumors 6502

    Let's Sekuhara!

    Joined:
    Jun 30, 2008
    Location:
    日本
    #3
    By "MR" I presume you are talking about the Japanese region-specific build of OS X 10.8 ..."Mountain Rion"

    Right?
    No?
    Not so much?
    ...ok, fine. I will disappear back into teh shadowz of teh interwebz from whence I came. And take my cheesy jokes with me. :rolleyes:
     
  4. macrumors 68020

    Comeagain?

    Joined:
    Feb 17, 2011
    Location:
    Spokane, WA
    #4
    Terrible joke you mean. We all refer to MacRumors as MR. Because we're lazy like that.

    I get the Blue pin wheel sometimes on lots of different websites. Nothing specific to Macrumors.
     
  5. macrumors 603

    Joined:
    Mar 29, 2008
    Location:
    Seattle
    #5
    I just started today getting the blue pinwheel javascript ball on Macrumors. Happening an awful lot. Any ideas, people?

    2012 iMac, 10.8.2, using Safari.
     
  6. arn, Jan 22, 2013
    Last edited: Jan 22, 2013

    arn
    macrumors god

    arn

    Staff Member

    Joined:
    Apr 9, 2001
    #6
    We made the site a little more Javascript intensive. But not massively so. We are lazy loading more items. So after the main page is displayed, Javascript loads additional items. The overall goal is to make the initial usable load faster, while later loading other items via Javascript.

    I'm not sure why you'd be getting slow-downs more than others though, esp with modern hardware.

    arn
     
  7. macrumors 603

    Joined:
    Mar 29, 2008
    Location:
    Seattle
    #7
    I'm not getting any "noticeable" slowdowns, that I can tell. I just really don't like seeing the pinwheel all the time. It's not actually affecting anything except drawing my attention to the cursor, because it looks like something bad is happening! Spinning wheels = bad!

    And yes, I'm not thrilled to be using Macrumors right now, that's for sure. :(
     
  8. macrumors P6

    Weaselboy

    Joined:
    Jan 23, 2005
    #8
    Odd you see it and I don't at all. 2012 13" MBA on 10.8.2 with Safari. :confused:
     
  9. macrumors 603

    Joined:
    Mar 29, 2008
    Location:
    Seattle
    #9
    Yep not sure what the dealio is. I'm curious as to what changed on the site in the last 24-or-so hours. Hopefully arn can reply again and say if the changes happened then or if it's something else.

    Interestingly, later today I haven't seen any blue pinwheels on Macrumors...

    (now watch it happen about 5 minutes after I post this!)
     
  10. Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Detroit, Michigan
    #10
    I'm not getting any blue pinwheels and the site is working fine for me. However I did notice that the formatting of the site is wider now. I only noticed because I had to adjust the width of my browser because it was getting cut off, where it wasn't a day or two ago.
     
  11. macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #11
    Zero beachballs here, but I noticed the wider format as well. I'd prefer it narrower, but it's not a huge deal.
     
  12. arn
    macrumors god

    arn

    Staff Member

    Joined:
    Apr 9, 2001
    #12
    We talking about the forums or the front page?

    arn
     
  13. arn
    macrumors god

    arn

    Staff Member

    Joined:
    Apr 9, 2001
    #13
    nevermind, I fixed it.

    arn

    ----------

    I already said: http://forums.macrumors.com/showpost.php?p=16706054&postcount=6

    arn
     
  14. macrumors 603

    Joined:
    Mar 29, 2008
    Location:
    Seattle
    #14

    Yes, you already said. But I was curious as to the timing. Was it in the last 48 hours, or was it a week or two ago that you made the site more java-intensive? I'm just trying to narrow down exactly when you made those changes. :)
     
  15. arn
    macrumors god

    arn

    Staff Member

    Joined:
    Apr 9, 2001
    #15
    Yep, just on Monday.

    arn
     
  16. macrumors 603

    Joined:
    Mar 29, 2008
    Location:
    Seattle
    #16
    OK cheers for the update. I'll have to see how it goes. Didn't see any more pinwheels after I posted. Did you change anything since the change?! :D
     
  17. arn
    macrumors god

    arn

    Staff Member

    Joined:
    Apr 9, 2001
    #17
    Nope, haven't changed the JavaScript.

    arn
     
  18. macrumors 603

    Joined:
    Mar 29, 2008
    Location:
    Seattle
    #18
    Very bizarre. Well thanks for the replies. Just have to hope the blue stays away!
     

Share This Page