Bluetooth MX1000 lagging?

Discussion in 'MacBook Pro' started by DigitalN., Jan 20, 2007.

  1. DigitalN. macrumors member

    Jan 3, 2007
    hey there, I am having a slight issue.

    I am using my MX1000 while I am at my desk, and every once and a while at random it will start having major slowdowns, and it will be a good 5-7 seconds behind when I move my mouse and it reacts on the screen. Any ideas? its really annoying, it happens alot.
  2. vansouza macrumors 68000


    Mar 28, 2006
    West Plains, MO USA Earth

    Go to logitech and get the newest drivers.
  3. DigitalN. thread starter macrumors member

    Jan 3, 2007
    there is none for mac.
  4. R.Youden macrumors 68020


    Apr 1, 2005
    I take it you are using the MX1000 that came with the desktop setup of keyboard and mouse. If that is the case then there is no Official support for the mac. The mouse should work fine but there is an issue with the keyboard which means it doesn't work. The only thing I can suggest is to make sure that the battery is OK, maybe try it out on a Windows machine to make sure that it is either a mouse or mac issue.

    I have just ordered one myself to use with my MBP and every report I have seen says that it works OK so I am interested to hear how you get on.
  5. DigitalN. thread starter macrumors member

    Jan 3, 2007
    Yes, it is from the MX5000 combo kit.

    But alas, even if my battery is fully charged, and I dont have anything else on bluetooth, it still lags. it is very annoying. I am going to call logitech tommorow (if I remember)

Share This Page