Bluetooth Wireless Keyboard & Mouse Keeps disconnecting

Discussion in 'Windows, Linux & Others on the Mac' started by ParagJ11, Jan 13, 2009.

  1. macrumors newbie

    Joined:
    Jan 13, 2009
    #1
    Hi,

    I installed Windows 7 on iMac 20 inch. All went smoothly and after lot of trail and errors, was able to recognize my apple wireless keyboard and mouse.
    All well till here.

    Now the problem is that these two devices keeps disconnecting very very often. For mouse, atleast i can move around and after few clicks, it starts working, but keyboard just doesn't work at all.

    I have to switch off the keyboard and then switch it back on to get it working for few more minutes. Is there a way I can resolve this?

    I've installed Bluetooth drivers from bootcamp 2.1 update for vista.

    Anyone else had this trouble, and anyone who'd be able to help me out.

    Thanks,
     
  2. thread starter macrumors newbie

    Joined:
    Jan 13, 2009
    #2
    Just an update on this,

    Now atleast I don't have to restart the keyboard all the time. I just need to hit the enter key and it takes about 2-3 seconds to get working. But, still the most annoying thing is that keyboard gets disconnected in 10-15 seconds.

    Can anyone please help me thru this or atleast suggest me few tips or tricks so that I could resolve this nagging issue.

    Otherwise, all is perfect, sound is there, aero is smooth and i managed to install VLC, skype and its working too.

    Thanks,
     
  3. macrumors 601

    gloss

    Joined:
    May 9, 2006
    Location:
    around/about
    #3
    Swap your Bluetooth drivers back to Windows Generic Bluetooth and you should remain connected.

    I had to use Apple's drivers to get my keyboard to pair, but had to switch back to the Windows drivers to get it to remain connected.
     
  4. macrumors newbie

    Joined:
    Jan 11, 2009
    #4
    Actually, you can also disable the "Allow the computer to turn off this device to save power" option in the Apple Built-In Bluetooth properties in the Power Management tab.
     
  5. macrumors newbie

    Joined:
    Nov 9, 2006
    #5
    You're right! Thanks so much. I figured it was a connection issue regarding power management, since the disconnection happened at specific intervals.
     
  6. thread starter macrumors newbie

    Joined:
    Jan 13, 2009
    #6
    Hi,

    I am not finding this option. can you please let me know how to disable this option ?

    Thanks,
     
  7. thread starter macrumors newbie

    Joined:
    Jan 13, 2009
    #7
    Power Management Did the trick

    oh you guys are brilliant. thank you..
    Power management option in Bluetooth device properties did the trick. Now both, keyboard and mouse work and stay connected like a charm.

    :eek:)
     
  8. macrumors newbie

    Joined:
    Oct 25, 2007
    #8
    Hi there.
    I'm using 10.5.6 here and I can't seem to find that option anywhere.
    Could you point out for the rest of use where to find the option to disable the "save power" option for the bluetooth keyboard?

    Thank you :)
    db
     
  9. macrumors newbie

    Joined:
    May 12, 2005
    #9
    For those having issues finding this, this option is under Windows.


    Start>Right Click Computer>Manage
    Device Manager on the left
    Expand Bluetooth Radios
    Right Click Apple Built-in Bluetooth>Properties
    Power Management tab
     
  10. macrumors newbie

    Joined:
    Aug 11, 2009
    #10
    not to interrupt but..

    ok im a slightly computer/incompetent boy who is trying to get windows to work on my imac (see side for tech specs).

    i can install win 32 fine using bootcamp and partitioning it and everything but when i try to get my drivers up w/ the Mac OSX installation disc the mouse and keyboard disconnect/turn off/im not sure.

    im figuring this is a problem with bluetooth hardware and I have looked all over the forums for something similar..

    Any help is greatly appreciated!

    ADVthanksANCE
     
  11. macrumors regular

    Joined:
    Oct 21, 2009
    Location:
    Canberra, Australia
    #11
    You mightn't be able to get that option because your running leopard and thus have Bootcamp 2, not Bootcamp 3 that works with SL. But I might be wrong.
     

Share This Page