BMW Bluetooth/iDrive system not working well with iPhone 4s CHIME IN iDrive OWNERS!

Discussion in 'iPhone' started by Texxy, Jan 25, 2012.

  1. macrumors 6502

    Joined:
    Aug 16, 2011
    #1
    So I set up my bluetooth in my BMW with iDrive. My friend also has basically the same car.

    In his car when his iphone is connected it shows all the recieved calls/missed calls and when you search for a name it pops/sorts out between all contacts by the letters you select on screen.

    BUT in my car with my iphone none of the above happens. I try to search for names and when I press a letter to narrow a search for a contact nothing changes on screen. No recieved calls or missed calls either.

    I was curious if it was the car or the phone so I took my fathers iphone (same as mine iPhone 4s with same update) and it worked PERFECTLY! Any ideas what could be wrong?

    I am sure many of you will be like "your phone is the problem" and the only reason I doubt my phone is the problem is because I LITERALLY replaced it last week for a new one.:confused:
     
  2. macrumors 68020

    mulo

    Joined:
    Aug 22, 2010
    Location:
    Behind you
    #2
    I think your phone is the problem, both my dads 4s and my 4 work flawlessly in his 2011 520d
     
  3. thread starter macrumors 6502

    Joined:
    Aug 16, 2011
    #3
    Tell me this, when you look on your contacts list, are your contacts just through iCloud or also syncd through your computer? I know a very random question but that is literally the only difference I could think of between my phone and my fathers.
     
  4. macrumors 68020

    mulo

    Joined:
    Aug 22, 2010
    Location:
    Behind you
    #4
    mine are synched through iCloud only, his through his computer and microsoft exchange
     
  5. thread starter macrumors 6502

    Joined:
    Aug 16, 2011
    #5
    Hmm...I have no idea then honestly. I have restarted my phone many times, disconnected bluetooth and whatnot.

    Some people were saying it could be because my contacts are syncd through iCloud but apparently not the case since you are syncd that way.

    Also people saying gmail accounts are through Microsoft xchange set to PUSH and I was like...HOW DOES THAT HAVE ANYTHING TO DO WITH THIS?

    :confused:
     
  6. thread starter macrumors 6502

    Joined:
    Aug 16, 2011
    #6
    Anyone else?
     
  7. macrumors 6502

    Joined:
    May 13, 2009
    Location:
    New Jersey
    #7
    I have an '07 328xi with idrive and i have no trouble with my contacts, etc showing up on the navigation screen. It's worked fine for my 3GS, iphone 4, and now my 4S
     
  8. thread starter macrumors 6502

    Joined:
    Aug 16, 2011
    #8
    Great for you but obviously there is some problem with my phone. My fathers and my friends iPhone 4s same specs except there's are 16GB work perfectly. Only difference of our phones is that I have a 32GB. ANYONE ELSE?!Please chime in!
     
  9. macrumors 6502a

    Joined:
    Aug 13, 2010
    #9
    2010 535i and all my contacts, missed call syncs and works fine.
    Either your phone or your car is defective. Btw new products can be defective, since your fathers phone worked fine and yours didn't that should narrow down the reasons it is not working .....
     
  10. thread starter macrumors 6502

    Joined:
    Aug 16, 2011
    #10
    Well I am 100% sure it is something with my settings/phone. I got another replacement from Apple and still same problem. It is not the car because the car works perfect with other iPhone 4s' I am sure I know what I am talking about. Any other thoughts?
     
  11. thread starter macrumors 6502

    Joined:
    Aug 16, 2011
    #11
    FINALLY FIGURED IT OUT! Alright so the iPhone 4s brought along STANDARD emoji option unlike before in 4 and below you would download an emoji app. So since it was standard I started using some emojis on my contacts which I guess BMW search could not recognize.

    Once I took off all the emojis in my contacts it worked PERFECTLY! Just stating my solution for the next person who needs help with this problem! My fathers phone had no Emojis on contacts so that is why his worked.

    But since I replaced my old phone, now the problem with this new phone is the BATTERY SUCKS! :confused:
     

Share This Page