1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

Boot from Disc Blue & White G3

Discussion in 'Macintosh Computers' started by jMc, Jun 10, 2005.

  1. jMc
    macrumors 6502


    I've just come into possession of a 350mhz Rev A Blue & White with a matching and stonking 21" Apple CRT. The machine has 768Mb RAM (2 256s and 2 128s), an additional IDE PCI card, a SCSI card and the stock graphics (Rage 128 Pro 16Mb). It also came with a second 80GB harddrive, but I've disconnected that temporarily, until I've got this machine up and running.

    I got the whole thing rather cheap (well £70 cheap) because the previous owner couldn't get the computer to boot - it would chime and then hang on a grey screen. It came with fully boxed versions of for OS9, OS8.5 and the original install and restore disc.

    Now, I've tried booting this machine off various discs, to the following results:

    i. OS9: hangs on grey screen (sometimes after a pointer has appeared)
    ii. OS8.5 also hangs on the grey screen (it's the kind of two tone pixelly grey, rather than a flat grey)
    iii. Original Restore disk: displays the Happy Mac, but then just sits there looking pleased with itself ;)
    ix. OS10.2: Boots! But the install always fails - once it just hung for an hour on 31 mins remaining, a couple of time's it's KP'd, and a couple of times it's got to the end of the install 'Running Installer Script' and then just crashed out with a white on black text screen reading 'The installer has unexpectedly quit, please restart your machine'.

    I now get the flashing question mark folder (I feel that's better than a grey screen, but it probably isn't) on trying to boot. Booting from CD still returns results as above.

    What I'm trying to do is install OS9, do the necessary firmware updates etc, then install OSX (Panther probably - I just haven't tried the discs yet), and use the machine (with the addition of a new Graphics card) as a media server.

    I'm going to start removing all the non-standard hardware and some of the RAM to see if that makes a difference, but I was just wondering if any of you had any further suggestions.

    Why can I boot from an OSX disc but not from earlier system discs?

    Unfortunately, B&W's are unable to boot over Firewire from my PB in TDM, however, I do have a G4 tower at work in which I could install the HD from the B&W and install the system to it - would reinserting the HD back into the B&W work, do you think?

    Sorry for the long post and thanks for any help in advance.

  2. macrumors 6502a


    Try resetting the motherboard. There are two buttons on the motherboard near the pram battery. I believe the left one is the cuda switch, and the right one is a reset button (what it resets, I don't know). Push the cuda button and hold for a few seconds. Also, remove a set of ram and try to boot, then remove the other. Remove all PCI cards except the video card. Have the hard drive you want to eventually boot from at the end (not middle) of the main IDE chain (in other words, physically install it right below the CD drive). Put the CD drive on the middle connector of the same IDE cable. Check the jumper settings of your hard drive and CD drive. Make sure they are master and slave (hard drive and CD respectively).

    Also, check and see if you have a Rev. 1 or Rev. 2 motherboard (google how to tell the difference--I don't know off the top of my head). If Rev. 1, get a Rev. 2 off ebay if you can.

    If you ever do get it booted, update the firmware to 1.1.1f4.

    Try taking the main processor out and carefully inspecting all the pins. Make sure they are straight, then reinstall.

    Check all pins on your hard drives and CD drive and motherboard IDE. I once had a similar problem that was related to bent bins.

    Try resetting the open firmware (follow the second bullet point of this page):


    Try reading this to see if anything is helpful:


    After all that, if it will not boot, you may have a broken computer. :(
  3. jMc
    macrumors 6502


    Thanks - that gives me another few options to try! I never knew there were any buttons on the logic board...

    I'm not actually that fussed if the machine is broken as I really just wanted the display - if I can get the G3 up and running it would be a rather nice bonus, but I could probably get most of the money I spent on it back by selling spares on ebay...

  4. macrumors 68000


    For what it's worth, it might also be the RAM - the B/Ws can sometimes have a finicky RAM controller (mine for example, will only accept 8x16 PC100 - the 16x32 which Apple claims will work in it gives me similar bizarre booting problems). Try double checking the types, speeds and densities of the installed RAM - sometimes pulling out the odd chip might actually be the solution.
  5. jMc
    macrumors 6502


    Thanks (been away - hence the tardiness of this reply...).

    FWIW it was a RAM problem. There were 4 sticks in there - 1 Apple branded 128, 2 Kingston 256s and one dodgy looking generic 128. After removing the generic 128 stick, I was able to boot...

    Happy days.

  6. macrumors 68010


    Had the same with my B&W. I removed the power for a couple of days and everything was fine. Probably some statical electricity. Also I could use 133 mhz ram in it, it hadn't had any problems with it.

Share This Page