Brand new i5 13" Air and severe flash player jumping

Discussion in 'MacBook Air' started by prvt.donut, Feb 29, 2012.

  1. macrumors 6502

    prvt.donut

    Joined:
    Jan 1, 2008
    #1
    :rolleyes:

    Wife's late 2010 11" MBA plays flash video great, it's only when playing 1080 flash video to the TV does it have trouble, but Plex fixes that.

    Then I get the 13" i5. Expecting much better performance, but just playing flash video gets about 2 frames a second, yet alone full screen and I haven't even bothered with connecting it to the TV!:(

    Anyone else had this problem?
     
  2. macrumors member

    Joined:
    Feb 6, 2012
    #2
    Same Problem

    Hey man i had the same problem but when i called applecare they just said check the internet speed and update to the latest flash player.:D
     
  3. rw3
    macrumors 6502a

    rw3

    Joined:
    May 13, 2008
    Location:
    DFW, TX
    #3
    Use Chrome when using everything that has Flash. Safari sucks at it and honestly, I hate Flash...it is the 90's of the internet.
     
  4. thread starter macrumors 6502

    prvt.donut

    Joined:
    Jan 1, 2008
    #4
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A405 Safari/7534.48.3)

    It's brand new, first flash page I went to said I had to install, so I installed flash from the Adobe site.

    Again, I have a 2010 MacBook air which uses only safari and can play back flash video just fine using the same Internet connection!

    I thought flash now offloaded processing to the GPU.
     
  5. macrumors 68030

    Joined:
    Jul 21, 2011
    Location:
    Los Angeles, CA
    #5
    Flash video over HDMI doesn't work. Plain and simple. The good thing is, everything that runs on crap....er flash....can be intervened with XBMC and/or Plex.
     
  6. macrumors 6502a

    Joined:
    Aug 8, 2011
    Location:
    Land of eternal Spring
    #6
    The 2010 Air has a better GPU and i do wonder if flash offloads to the HD3000 in OSX or not.

    Even so sometimes i have slowdowns on my iMac :(
     
  7. macrumors 68040

    MBHockey

    Joined:
    Oct 4, 2003
    Location:
    New York
    #7
    I have the same MBA (2011, 13" i5) and I don't have problems watching 1080p trailers on Youtube. Can you post a link to the video that is giving you problems?
     
  8. macrumors 68000

    ryannel2003

    Joined:
    Jan 30, 2005
    Location:
    Greenville, NC
    #8
    I've run flash videos from my 13" MBP to my 32" Vizio using HDMI and it's never stuttered before. I would think the Air could do this as well.
     
  9. macrumors 68030

    Joined:
    Jul 21, 2011
    Location:
    Los Angeles, CA
    #9
    I have a mac mini plugged into my 46" thru HDMI and it sucks at playing 1080p flash. H.264 1080p plays smooth as anything tho! If I try playing hulu full screen it runs like crap. If I run hulu thru XBMC it plays perfectly. I can play it smoothly with flash if I change my refresh to 24hz...but it will micro stutter occasionally....which leads me to believe that its not a capability problem, its a flash video frequency problem...it just doesn't sync with a tv well.
     
  10. thread starter macrumors 6502

    prvt.donut

    Joined:
    Jan 1, 2008
    #10
    That's weird, today it is playing them well... :confused:

    If you want to watch flash video full screen though a HD TV, get plex and install video plug-ins for the content. Or set the screen to mirroring and the resolution to 720p.

    :D
     
  11. thread starter macrumors 6502

    prvt.donut

    Joined:
    Jan 1, 2008
    #11
    Spoke too soon.

    Some videos still play awful. Safari beach balls, and freezes a lot.

    Not all videos do it. Some youtube videos play like that, others are fine.:confused:
     
  12. macrumors 6502

    phairphan

    Joined:
    Sep 21, 2005
    Location:
    Reject Beach
    #12
    Make sure you are actually playing Flash on Youtube. Youtube has a nasty habit of kicking me into the HTML5 beta group. HTML5 video on Youtube is HORRIBLE. It's beach ball city on everything from my Air, to the Mini connected to my TV, to my Mac Pro. Not all videos are available in HTML5, so that might explain why, at the same resolution, some videos work well and others don't.
     
  13. thread starter macrumors 6502

    prvt.donut

    Joined:
    Jan 1, 2008
    #13
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A405 Safari/7534.48.3)

    I did think maybe it's an issue with YouTube formatting.

    How do you know if they are going to use html5? Is there a way of making sure it never uses it?
     
  14. thread starter macrumors 6502

    prvt.donut

    Joined:
    Jan 1, 2008
    #14
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A405 Safari/7534.48.3)

    Saying that though, it's weird I don't have any issues with the other MBA!?!?
     
  15. thread starter macrumors 6502

    prvt.donut

    Joined:
    Jan 1, 2008
    #15
    HTML5!

    DAMN YOU!

    If you experience this problem of safari freezing and video being horrific in youtube, then it is true, HTML5 is the cause.

    you have to right click the video, and there is an option to go to the youtube HTML5 options page, where you can then opt out of the offending scheme.

    It is weird that Apple has been saying that HTML5 will make Flash redundant, but then their OSX web browser doesn't support it.:rolleyes:
     
  16. macrumors 6502

    phairphan

    Joined:
    Sep 21, 2005
    Location:
    Reject Beach
    #16
    Glad you figured this out. Given your problems, I was fairly certain HTML5 was the culprit. Don't be surprised if you occasionally get moved back into the HTML5 beta. I really don't understand how it can work fine on an iPhone, but bring a Mac Pro to a crawl.
     

Share This Page