1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

Brand new MBA 2012, Internet not working

Discussion in 'MacBook Air' started by Jonny Craig, Dec 27, 2012.

  1. macrumors newbie

    #1
    I just got my MBA 2012 13 inch. It has ML already installed

    I can connect wirelessly to my network and it shows that I am connected. However when I go to Safari it will load the apple page but that's it, I can't go to any websites. It just loads the blue bar partially and doesn't do anything.

    I half expected this bc I heard Mac is not friendly with all routers, but my router is pretty new.

    Does anyone know what are the things I can do to fix this? I already turned off Bluetooth and that didn't help\

    Edit: okay literally as soon as I posted this I was able to get to a few other websites. I'll keep testing to see if it's for real
     
  2. macrumors newbie

    #2
    Ok I've diagnosed my own problem

    Wifi is perfect outside of my room, getting 30 MB/s download speeds in the hallway and 4 MB/sec in my room if I'm on my bed. If I sit at my desk it can barely even load a web page

    This is not good lol. My crappy Windows laptop has no issues with Wifi even in my room so what's with this? Is there any way to boost the signal or does the MBA wifi just suck?
     
  3. macrumors 6502

    #3
    My friend had the same issue on his MBA and his iMac works just fine under the same router. He took it to the Apple store to have it replaced.
     
  4. macrumors 65816

    #4
    try switching your router to Ch 1 and see if that helps
     
  5. macrumors newbie

    #5
    It seems to be working better now, I have no idea what I did. Disappointed that the speeds are drastically slower in my room but I'll be moving in a few months to a house where my room will be closer to the router so I'll deal :apple:
     

Share This Page