Broken: Application Folder in Home Folder

Discussion in 'OS X' started by suicidal nun, Jan 29, 2008.

  1. macrumors member

    Joined:
    Jan 29, 2008
    #1
    Before I start, some basic background information: I use a Dell monitor with my laptop (MBP 2.16 dual core with 10.5.1) and often I run a single screen set up with an external keyboard and mouse.

    Here's what happened: My laptop was "open" when I plugged the monitor's DVI in and it went into a dual screen setup. I closed my laptop and naturally, it went to sleep. It's somewhat difficult for me to wake it up after doing so (which is why I prefer plugging in my monitor when my laptop is already closed) because it requires some random button pressing and mouse clicking to wake it up.

    When my laptop woke up, I found that through my random button mashing, I accidently rewrote the name of the Application folder in my Home folder. This is not the Application folder you find in Systems. This is the "shortcut" folder in Home that takes you to the actual folder and well, I broke that shortcut. When I click on it, I get a empty folder. I don't know how to fix it or how serious this error is since that folder is not quite an alias. My other folders (Documents, Movies, etc) works just fine so...

    EDIT: I did rename it back to Applications, but no cigar. Any other ideas? :)
     
  2. macrumors G4

    Eraserhead

    Joined:
    Nov 3, 2005
    Location:
    UK
  3. Administrator emeritus

    xUKHCx

    Joined:
    Jan 15, 2006
    Location:
    The Kop
    #3
    Not totally sure which folder you mean but the application folder /Users/username/Applications is not a link to the folder /Applications. It is a where applications that are only available to you are stored. My /Users/username/Applications is empty as I have all applications available to all users.

    You can just rename it back to applications.
     
  4. thread starter macrumors member

    Joined:
    Jan 29, 2008
    #4
    of course I did this, but sadly that's not the fix.
     
  5. macrumors newbie

    Joined:
    Jan 29, 2008
    #5
    Are you talking about Finder?

    Are you talking about the "Applications" alias on the left-hand side of Finder? If so, navigate to Macintosh HD and click and drag "Applications" back over. Delete the mangled alias.

    You can also hold down option-command to create an alias.
     
  6. thread starter macrumors member

    Joined:
    Jan 29, 2008
    #6
    No, I'm talking about the Application folder/alias that is in the Home (user) folder. Not the Application in the sidebar.
     
  7. macrumors 6502a

    Joined:
    Aug 13, 2007
    Location:
    Not where you live.
    #7
    Was there anything in the users/you/Applications folder?

    I don't even have one as all my applications are installed for all users. My Applications folder is in the root of my hard drive.

    If there was nothing in it, don't worry about it.
     
  8. thread starter macrumors member

    Joined:
    Jan 29, 2008
    #8
    yeah when i opened it, it would take to my application folder. much like clicking on the document/movie/picture/etc folder.
     
  9. Administrator emeritus

    xUKHCx

    Joined:
    Jan 15, 2006
    Location:
    The Kop
    #9
    You must have created an alias because the Applications folder that is sometimes in the home directory is a separate applications folder altogether, see my previous post.

    That said why don't you recreate the alias. Double click on your Harddrive to get to the root where you will see Applications, Library, System, Users. Control-click (right clicj) on Applications - "Make Alias". Then move it to your home folder.

    You can rename it Applications and give it the correct icon. To do this select the proper applications folder and press cmd+I then in the information window select the icon at the very top and press cmd+c. Then cmd+I on the alias and select the icon at the top and press cmd+v.
     
  10. macrumors newbie

    Joined:
    Jun 22, 2008
    Location:
    USA
    #10
    Same problem here.

    New iMac user. When I first set up computer there was an applications folder in my homefolder and each time I would install an application it would put an icon of the application in both the application folder in my home folder and the application folder on the HD. So, somehow like the original poster I lost all the apps icons that were in the homefolder/user/applications folder when I was trying to make a stack of that folder on my dock. My apps icons still show up in the HD apps folder that I see in the sidebar.

    Anyways the applications folder still sits in the homefolder/user/ location but there are no listed applications in it. Of interest is that now when I install a new app it shows up in the original apps folder located in the sidebar but not in homefolder/user/applications folder.

    So, I am wondering if I have broken my user preferences somehow. I had only wanted the apps accessible to the one user and so I assume this is why they were being put in that location? Or, are you all saying that when a homefolder/user/applicationsfolder is originally created to hold apps only for that user that they are only aliases anyway?

    using: iMac, Lep 10.5.3
     
  11. macrumors newbie

    Joined:
    Sep 21, 2007
    Location:
    Netherlands
    #11
    The Application map is directly under the root of the HardDrive. Not in your user map
     
  12. macrumors newbie

    Joined:
    Jun 22, 2008
    Location:
    USA
    #12
    ANybody?

    Pendora, I realize that, it still doesn't explain my problem.

    Still looking for answers?
     

Share This Page