Broken QT7 Export Deinterlace: I Finally Figured It Out

Discussion in 'Digital Video' started by Makosuke, Jun 17, 2006.

  1. Makosuke macrumors 603

    Aug 15, 2001
    The Cool Part of CA, USA
    Ok, I posted here roughly a year back trying to figure out how to get QT7 to deinterlace a DV clip on export to large-frame h.264. After literally three days of experimentation, I thought I had the solution:

    1) Create a reference movie with Deinterlace (or Single Field--having both on is the same as single field) selected. High Quality, too, if you want.
    2) Size the reference movie approprately, and save it.
    3) Export the movie as a .mov using 29.97fps (I'm assuming NTSC here) and leave the size "as is" in that section of the export dialogue.

    If you DON'T set the framerate, or you are so audacious as to try and set the export size in the export dialogue, it turns off whatever deinterlace options you selected, and you get an export that looks like garbage.

    As it turns out, there's one more thing I was missing here.

    4) You MUST resize the clip from it's original size, even if it's only by a single pixel.

    Now, I just spent an entire day of wasted encodes trying to figure out #4 there, because I used the handy built-in recorder in QT Pro, set to "passthrough", to record a DV stream and save time instead of going through iMovie. Except for one thing I didn't count on: iMovie captures DVD at 720X480 (non-square pixels), while through whatever method the passthrough produces a file at 640X480.

    Since my target export size was 640X480, when I was rescaling the iMovie imports, I was accidentally meeting criteria #4, while with the simplified capture video, it was literally impossible to get a deinterlaced export unless I resized it (again, even a single pixel smaller kicks in perfect single-field deinterlacing).

    Now, QT 7.1 (or maybe 7.1.1, I can't remember which, as I upgraded in the middle of my experimentation) FINALLY adds a functioning deinterlace option (as well as some bonus controls) to that problematic Size setting in the export dialogue.

    This is very nice, and ACTUALLY WORKS, but for one caveat: It does deinterlacing, not single field. If you don't mind the "overlapped" frames of a straight-deinterlaced source, then this is ok. But if you prefer the lower-rez but clean-framed Single Frame option for whatever reason, you need to jump through all of the above hoops to get it.

    Ugh. I hope this benefits somebody. I want to find whoever was responsible for the decision to make the quality/deinterlace/single field flags not apply to exports UNLESS you resize the output and stab him or her in the foot with a fork. You could technically argue that this is not a bug, as those are playback options, but they're valuable for export too, and WYSIWYG is supposed to be the norm. Judging by the number of annoyed people on the QuickTime Dev List who were basically told to use the $500 Cleaner for this, the fact that it borders on an unsupported hack is a boneheaded ommission from an otherwise great product.
  2. nykije macrumors newbie

    Oct 12, 2007
    alternate method?

    Did you try to set deinterlacing and quality options in the actual export process (file/export/options/size/"Deinterlace Source Video")
  3. Makosuke thread starter macrumors 603

    Aug 15, 2001
    The Cool Part of CA, USA
    I posted that well over a year ago and haven't done much encoding since, but yes--if you read what I said I note that the "Deinterlace Source Video" added at some point along the line solves the "no deinterlace" bug, but it has the side effect of doing "straight" deinterlacing rather than single-field, which produces higher-resolution output but the sort of double-vision effect you get from that.

    If you want single-field deinterlacing you still need to jump through the hoops. Or did as of mid-2006--this may have been changed in the latest versions of QT. I haven't tried.
  4. powersms71 macrumors newbie

    Nov 14, 2007
    Need Help with Deinterlace with QT API

    Hi there,

    I've been trying to figure out how to do this same thing -- specifically
    using the Quicktime API. Have you been able to Deinterlace videos
    using Quicktime's C/C++ API? Or, have you just used Quicktime Pro?

    Even if you just used Quicktime Pro, can you explain how to do it?
    I've tried exporting a movie to a Quicktime Movie with the "Deinterlace
    Source Video" checkbox checked, but it doesn't look like it worked.
    In addition, what we really want to do is to take a source movie,
    de-interlace it (if needed), and then, Export it to h.264 (or De-interlace
    as part of the Export). Do you know how to do that?

    Anyways, any help would be greatly appreciated. Thank you so much!

  5. vocaro macrumors regular

    Mar 5, 2004
    I didn't have to do any resizing.

    I too was having problems getting QT7 to deinterlace on export. I had imported an NTSC VHS tape as DV via the Canopus ADVC-300 using QuickTime Pro 7.3.0. On playback, the video was deinterlaced, but after exporting to H.264, the result was interlaced.

    The trick was to click the Options button in the save box, then in the video settings click the Size button. That brings up an option for "Deinterlace Source Video". Checking this box caused the exported video to be deinterlaced.
  6. Makosuke thread starter macrumors 603

    Aug 15, 2001
    The Cool Part of CA, USA

    Didn't see your post until now since I wasn't really paying attention to such an ancient thread, but I don't have any suggestions for you. I only use QT Pro--never accessed the API directly.

    The checkbox in the export section works fine for me, although as I mentioned it appears to do "regular" vs. single-field deinterlacing, not that that matters for the most part.

    Not sure why it isn't working for you--perhaps the source video was encoded as single-field video even though it should have been deinterlaced? I've seen this a couple of times, and there's not much that QT can do with it, since it can't really detect the interlacing. I'm sure there'd be a way to work around it by sort of "re-interlacing", but usually that sort of video has really horrible compression artifacts anyway.


    Um... yes, as I pointed out in the post above. Note that it was from 06-17-2006--well over a year ago--and toward the bottom I actually noted that they added the checkbox in the options section of export at some time around QT 7.1, which was released during my fighting with this issue originally.

Share This Page