browser woes...

Discussion in 'Mac Apps and Mac App Store' started by blackfox, Jul 15, 2004.

  1. blackfox macrumors 65816

    blackfox

    Joined:
    Feb 18, 2003
    Location:
    PDX
    #1
    OK, this is half a cry for constructive help, and half just a complaint on my part...but here is the story.

    Up until a couple weeks ago, I was happily settled on Firebird (1.4) as my browser...it was fast, worked well, had a search feature built into the taskbar...yada, yada.

    Then, I accidentally disconnected my External CD-R Drive, with disk on desktop, and it ended up hanging my computer, eventually forcing me to manually restart.

    When I rebooted, everything worked fine, except Firebird had lost the ability to paste links in the taskbar, a very important feature for me. So I posted a thread asking what might have happened and what I could do. The solitary poster who responded suggested I try the new Firefox .92, which I did, and was impressed...initially.

    Then, Firefox began to lag considerably, and have real trouble displaying flash banners and the like, as well as a host of other display quirks. I do not know why.

    So, I also tried Safari, which is only at 1.02, since I have Jag and not Panther. Works pretty well, except that it has some issues scrolling back between pages and "remembering" where I have been (for example, @Hotmail, it will display my mail as new, no matter if it has been read or not...and threads at this site remain highlighted after reading or contributing)

    So I also tried the main Mozilla browser(1.4). It works pretty well, although it does not have the search feature in the task bar, and the tab system is kinda overly complex. Fair speed. Also has trouble with Flash ads.

    So I also tried Camino, which is my back-up browser anyway. It takes forever to load, but once up, works well with none of the problems listed above but for the search feature in the taskbar. Still slower than I remember, though...

    So what gives? I cleaned out my preferences, fixed permissions, generally cleaned house on my HD, in case it was my computer's (re:my) fault that my browsers were performing poorly...but same problems...I also had my first kernal panic yesterday in over a year...I was not browsing, but a browser was open. Anyone have any ideas? On what might be wrong, with my computer or my browsers?Browser recommendations? I am at a loss...but thouroughly dissatisfied. Help.
     
  2. jeremy.king macrumors 603

    jeremy.king

    Joined:
    Jul 23, 2002
    Location:
    Fuquay Varina, NC
    #2
    You don't mention what kind of hardware you are running. If its older, I think you will have to tolerate some of the speed such as launching delays. If its newer, I would seriously consider getting a copy of Panther, as its a bit more stable. As for some of the page loading lagyou are experiencing, I would try to ping using Terminal to make sure there isn't any problems with your DNS lookups.

    Finally, You seemed too bothered that there is not a search feature in the taskbar, which I find troubling. Is it really that hard to type www.google.com in the address bar?
     
  3. blackfox thread starter macrumors 65816

    blackfox

    Joined:
    Feb 18, 2003
    Location:
    PDX
    #3
    kingjr3, I have relatively outdated hardware...(g3 900), but I wonder of the relevance, since I have always had this hardware, and the problem(s) are new. As far as Panther, I have been deliberating, but since I will be buying a new machine in the beginning of 2005, I will either get a free copy then, or move straight to Tiger...

    As far as the search feature, yes, it is not difficult to type google manually, I am just used to a certain system/flow with my use of tabs, it is just an inconvenience...
     

Share This Page