Buy more bandwidth, Apple!!!

Discussion in 'iPod' started by MattG, Oct 18, 2005.

  1. macrumors 68040

    MattG

    Joined:
    May 27, 2003
    Location:
    Fletcher, NC
    #1
    Holy crap is iTMS slow!!!

    It's been a while since I've purchased any music on here. I'm going on a trip and decided to buy a bunch of music before I go. It's taking F O R E V E R! I hit "Purchase," walked away and came back 10 mins later...and it was still downloading the first song! I cancelled it and went back in, and now it's going a little faster, but not as fast as it used to. Is it always like this now?

    I guess it's a good sign, though...no slowing down for Apple!
     
  2. macrumors 65816

    ipacmm

    Joined:
    Jun 17, 2003
    Location:
    Cincinnati, OH
    #2
    Are you sure it isn't your internet on your computer? because itunes store on my computer is really fast.
     
  3. thread starter macrumors 68040

    MattG

    Joined:
    May 27, 2003
    Location:
    Fletcher, NC
    #3
    Nah, we've got a pretty quick connection here. Everything else is fast enough...
     
  4. macrumors 6502

    Joined:
    Jan 15, 2005
    #4
    I have not had an issue with iTunes... I have been buying a few videos recently and they have been downloading very well. I bought the first episode of Lost the other night and I believe it finished downloading around 5-6 minutes..
     
  5. macrumors 65816

    ipacmm

    Joined:
    Jun 17, 2003
    Location:
    Cincinnati, OH
    #5
    I don't know what to tell you, the store works fine on my end...but I do agree, Apple should buy some more bandwidth because it would never hurt to have extra.
     
  6. macrumors regular

    Joined:
    May 15, 2004
    Location:
    Cville, VA
    #6
    a few days ago it was REALLY slow (rest of the internet was still zippy as usual). its going really fast for me today. so it wasnt just you and hopefully they fixed the issue.
     
  7. macrumors 603

    solvs

    Joined:
    Jun 25, 2002
    Location:
    LaLaLand, CA
    #7
    Could be a firewall issue, or just a fluke. I've had it get slow for awhile for no reason, then speed up again. Maybe it's the Tues updates.
     

Share This Page