Calibrated ibook battery goes from 76% to 0% in a snap

Discussion in 'PowerPC Macs' started by hookem12387, Feb 21, 2008.

  1. macrumors 6502

    My ibook G4 (running leopard) has a battery that seems to drop from around 75% to the computer shutting down completely (ncluding loss of prefered wifi network) in literally the blink of an eye, with no warning. I have calibrated it. I tried running coconut battery to see its vitals and the program tells me crazy things like it can charge to 12666mAh which we all know is impossible. Any ideas at all?

    The apple info says it has around 206 cycles on it total. Do I need to just cough up and buy a new battery? I'm hoping not as I just got the computer used through the marketplace and the guy before said he was getting 2-3 hours still. I'm just wondering what I'm doing wrong?? Thanks a ton
  2. macrumors 6502

    Does anyone think that resetting the Pmu might help?

    Edit: Ok when I just ran a new battery health monitor it shows that my battery is basically dropping from 2400mAh of charge to 24mAh. Is this just new battery time?
  3. macrumors 68020


    So what happened with your mac? My wife had one which is doing the same thing- but she has five hundred+ cycles on it. I just don't want to buy a new battery and find out it is also another problem.
  4. macrumors 68030


    I know the original OP has likely solved his problem, but to you and anyone with a crappy iBook battery -- you might be eligible for a free replacement.

    Mine had similar issues and I happened upon this website on Apple's website.

    Check and see if your battery qualifies for the recall. I got a free battery replacement just last month.
  5. macrumors 68020


    Unfortunately it isn't- it is a 14" ibook. We had the battery replaced once and I guess they gave us a decent one. My wife uses the battery at least one full charge daily so that is why it drained so quickly I guess. Thanks for the help.

    My wife's computer does the exact thing as the is around the 70% range and then shuts down with no warning- just black. Anyone have any thoughts?

Share This Page