Caller Id displays 011 1 before number. Does not display names.

Discussion in 'iPhone' started by DAlba, Jun 30, 2007.

  1. macrumors newbie

    Jun 30, 2007
    Sync'd contacts using apple address book. Everything looks fine in address book accept for caller id. Same address book works fine on my Treo. Any suggestions?
  2. thread starter macrumors newbie

    Jun 30, 2007
    Ok, so it appears to be doing it with just one number which happens to be my other cell phone number on my Treo.

    I took the sim card out of the treo and put it in another phone. Called my iPhone and it does the same thing.

    Tried erasing the contact number and re-entered. Same problem. If I store my number in contacts with the 011 1 before it; the caller id works. Also, if i enter my number in contacts without the area code it works. This is very weird.

    Any suggestions??
  3. macrumors newbie

    Nov 19, 2007
    I have the same issue only with calls from other AT&T phones

    I have the same issue from calls from other AT&T phones. All my ohter calls work OK.
    I called AT&T and the support guy was clueless.
    I asked him to open a ticket on it, since it appears to be an AT&T issue.
  4. macrumors 68040


    Aug 6, 2007
    My iphone started displaying caller id from my home phone with ane extra 1 in front of it, so it goes like 11301xxxxxxx instead of 1 (301) xxx-xxxx. No spaces, no ( ) on the area code. And when you try to recall that number it obviosly won't go through. No one seems to haver a clue why. This doesn't happen on every number calling me, just some.

Share This Page