Camera failed error on Samsung galaxy s3. Any solution?

Discussion in 'Alternatives to iOS and iOS Devices' started by gaiao, Apr 20, 2013.

  1. macrumors newbie

    Joined:
    Jul 18, 2012
    #1
    I keep getting this message when I try to use the camera : "error camera failed". Then I have to restart my phone in order for the camera to work again. It doesn't happen all the time but it's very annoying when it does.... I did some research and this seems a common problem in android phones but I didn't find a fix. Has anyone here had this problem? Were you able to fix it?
    I even did a factory reset but the problem persists...

    My phone is a Samsung galaxy s3 (international version).

    Thanks!
     
  2. adder7712, Apr 20, 2013
    Last edited by a moderator: Apr 21, 2013

    macrumors 68000

    adder7712

    Joined:
    Mar 9, 2009
    Location:
    Anywhere
    #2
    Try a battery pull while the phone is powered up.
     
  3. gaiao, Apr 20, 2013
    Last edited by a moderator: Apr 21, 2013

    thread starter macrumors newbie

    Joined:
    Jul 18, 2012
    #3
    I will try it next time! I read it may be some app interfering with the camera... but not sure which one...

    Well. Thanks anyway!!!! :)
     
  4. macrumors 6502

    Joined:
    Oct 26, 2012
    Location:
    Undecided
    #4
    Have you done any modding to the phone? Things like flashing a new kernel or ROM can break stuff like this. Otherwise, just try uninstalling any apps you've installed recently.

    If you are on the stock ROM, go flash something better...goodness...stock ROMs scare me....
     
  5. thread starter macrumors newbie

    Joined:
    Jul 18, 2012
    #5
    I never did any modification on the phone... I'm always afraid of doing something wrong with it or bringing more bugs into it... I will try to uninstall some apps that use the camera and see what happens.
     
  6. macrumors 68000

    adder7712

    Joined:
    Mar 9, 2009
    Location:
    Anywhere
    #6
    If persists after a full reset then an App isn't interfering.

    Is it still under warranty? If it is, take it back to Samsung or your carrier.
     
  7. thread starter macrumors newbie

    Joined:
    Jul 18, 2012
    #7
    It is still under warranty... but the weird thing is: it doesn't happen all the time.... and just restarting the phone fixes it... so I was thinking it could be a software problem...
     
  8. macrumors 68040

    0dev

    Joined:
    Dec 22, 2009
    Location:
    127.0.0.1
    #8
    I had a similar problem on my HTC, the camera would fail sometimes and restarting would fix it. I found this problem persisted on multiple ROMs and after factory resets so it was certainly down to the hardware. My HTC had a plethora of problems...

    Anyway, try a factory reset. If the issue persists, you know it's the same as my issue and it's a hardware fault. Since you're still under warranty just get it swapped out or repaired.
     
  9. MRU
    macrumors demi-god

    MRU

    Joined:
    Aug 23, 2005
    Location:
    Ireland
    #9
    Have you tried a different camera application such as camera+ or the basic jellybean camera software and see if the image persists in those too.

    If they work its not hardware it's software. If they fail to initialize too, then it's hardware and go get a warranty replacement / repair :)
     
  10. thread starter macrumors newbie

    Joined:
    Jul 18, 2012
    #10
    I tried other camera applications and had the same problem.
    Well I'm going to contact samsung.


    Thanks everyone!
     
  11. MRU
    macrumors demi-god

    MRU

    Joined:
    Aug 23, 2005
    Location:
    Ireland
    #11
    Yep has to be hardware so. Good luck, hope its replaced quick smart for you. :)
     
  12. macrumors newbie

    Joined:
    Jul 1, 2013
    #12
    hi there, i have the same problem.... someone has been able to fix it? :confused:
     
  13. thread starter macrumors newbie

    Joined:
    Jul 18, 2012
    #13
    Mine was fixed after I disabled Location and Google Search (inside Location services). So, its not a hardware problem... Its been more than a month without having this bug.
     
  14. macrumors newbie

    Joined:
    Oct 2, 2011
    #14
    it started for me when I loaded ooVoo I uninstalled it and everything returned to normal with the camera. I did NOT even have to restart the phone.
     
  15. macrumors newbie

    Joined:
    Aug 16, 2013
    #15
    My camera still does not work ive tried a battery pull and a factory reset. What can i do.
     
  16. macrumors newbie

    Joined:
    Aug 16, 2013
    #16
    It says inserted sd card:change storage location to sd card, how do I do that.
     
  17. macrumors 68000

    Southernboyj

    Joined:
    Mar 8, 2012
    Location:
    Mobile, AL
    #17
    I had this exact same issue on my HTC One. I was using a custom ROM though.
     
  18. macrumors newbie

    Joined:
    Nov 12, 2014
    #18
    Samsung S3 mini - camera disconnected

    Hi!
    I don't know if anyone is still having an issue with this "camera Failed" error but I just fixed a colleague's Samsung S3 mini. He spilled some coffee on his speaker and opened his phone in hopes that drying it would help (it didn't) but when he opened his phone, the small flap where the camera 'connection' is held was opened too and the camera was therefore disconnected. The error only occurred after he opened it and never happened before so I opened the phone again and found the problem. Make sure the little connection is securely fastened over the camera cable (more like a little flat film) and then put your phone back together carefully so you don't disconnect it or anything else. It worked whereas the resets (factory and battery pulls) as well as the cache/data clearing did not.

    Just something to look at if you opened your phone before and the camera is now giving you that error.
     

Share This Page