Can someone please explain this warning to me? (Apple Mach-O Linker (ID) Warning)

Discussion in 'Mac Programming' started by chrono1081, May 4, 2011.

  1. macrumors 604

    chrono1081

    Joined:
    Jan 26, 2008
    Location:
    Isla Nublar
    #1
    Hi guys,

    I'm dusting off my OpenGL Superbible and going at it again and I was setting everything up in XCode 4 (The book uses three but I don't think that matters).

    Anyway I got everything running except I get this warning that I don't know how to resolve.

    I attached a picture of them so that it is easier to see (since the warnings wont copy and paste in) but also have included it here. The project runs and builds perfectly fine, but for some reason this error still shows up.

    Here is the error but attached is a picture too:

    Code:
    Ld /Users/Scott/Library/Developer/Xcode/DerivedData/Bounce-fusprttlfrzukfczwsiukhvyculg/Build/Products/Debug/Bounce.app/Contents/MacOS/Bounce normal x86_64
        cd /Users/Scott/Documents/OpenGL/SB5/Src/XCode/Chapter02/Bounce
        setenv MACOSX_DEPLOYMENT_TARGET 10.6
        /Developer/usr/bin/llvm-g++-4.2 -arch x86_64 -isysroot /Developer/SDKs/MacOSX10.6.sdk -L/Users/Scott/Library/Developer/Xcode/DerivedData/Bounce-fusprttlfrzukfczwsiukhvyculg/Build/Products/Debug -L/Users/Scott/Documents/OpenGL/SB5/Src/XCode/Chapter02/Bounce/../../../../SuperBible55/XCode/GLTools -L/Users/Scott/Documents/OpenGL/SB5/Src/XCode/Chapter02/Bounce/../../GLTools -F/Users/Scott/Library/Developer/Xcode/DerivedData/Bounce-fusprttlfrzukfczwsiukhvyculg/Build/Products/Debug -filelist /Users/Scott/Library/Developer/Xcode/DerivedData/Bounce-fusprttlfrzukfczwsiukhvyculg/Build/Intermediates/Bounce.build/Debug/Bounce.build/Objects-normal/x86_64/Bounce.LinkFileList -mmacosx-version-min=10.6 -framework Cocoa -framework GLUT -framework OpenGL -lGLTools -o /Users/Scott/Library/Developer/Xcode/DerivedData/Bounce-fusprttlfrzukfczwsiukhvyculg/Build/Products/Debug/Bounce.app/Contents/MacOS/Bounce
    I don't know much about what this error actually is since everything works fine. Any help would be greatly appreciated :)
     

    Attached Files:

    • pic.png
      pic.png
      File size:
      105.8 KB
      Views:
      156
  2. thread starter macrumors 604

    chrono1081

    Joined:
    Jan 26, 2008
    Location:
    Isla Nublar
    #2
    Oh now I really screwed it up. I deleted my default search paths since that was one solution I saw online (and it broke my program) and now I can't insert the old search paths back in :(
     
  3. macrumors 68030

    jared_kipe

    Joined:
    Dec 8, 2003
    Location:
    Seattle
    #3
    Alright lets start with simple here, reinstall XCode from a downloaded image from Apple.
     
  4. thread starter macrumors 604

    chrono1081

    Joined:
    Jan 26, 2008
    Location:
    Isla Nublar
    #4
    I'll have to give that a try. I thought it was an error in the code somewhere and there is almost nothing relevant online about the error (or if I find something people say they fixed it but don't say how :( )

    For now I have a workaround of just creating new projects and copying the authors code in and running it that way for now.
     

Share This Page