Can someone tell me how to access my Apple TV's frontrow folder using Fugu?

Discussion in 'Apple TV and Home Theater' started by marklight, Jul 14, 2008.

  1. macrumors 6502

    Joined:
    Apr 6, 2006
    #1
    I've already used a patchstick on the apple tv, but now im ready to start moving over some plug ins- but I really don't know anyting about Fugu and what information to give it to access the apple TV
     
  2. macrumors 6502a

    Philberttheduck

    Joined:
    Mar 15, 2006
    Location:
    HB, CA
    #2
    appletv.local

    port 22

    username: frontrow

    go to advanced sftp options and check "force ssh1 connection to server"

    connect

    password: frontrow

    drag and drop
     
  3. macrumors member

    Joined:
    Jan 3, 2009
    Location:
    Illinois
    #3
    Okay, so I see that this post is from '06, and it's now '09,... but i just got an ATV and i've been getting so frustrated with just trying to install codecs and connect my external hard drive.

    I've used the ATVUSB creator from google, I'm running 2.1 on the ATV, and I'm using 10.5.6 on my intel iMac.

    finally- HERE is my frustration- I'm not that great with Terminal, so i too am using Fugu, but it will not let me Force SSH1... has anyone else had this problem? someone PLEASE help me out.

    when i click "force SSH1" and connect, it looks like it tries for a brief second, then it just goes back to the connect screen.

    is this because i'm reading into the past before take 2, and before leopard?

    Again-
    ATV 2.1
    Leopard 10.5.6
    Aluminum 20" iMac intel 2.66Ghz
     
  4. macrumors 6502

    Joined:
    Jan 20, 2008
    #4
    It's been a while since I messed around with hacking the AppleTV (didn't really benefit my workflow) but I'm pretty sure I had this problem before as well.

    What worked for me was changing it from appletv.local to the actual ip (found somewhere on the appletv itself, i think it's buried in settings, network maybe?)

    That usually solved it.
     
  5. macrumors member

    Joined:
    Jan 3, 2009
    Location:
    Illinois
    #5
    Crap, that didn't work either.

    Thanks for Responding. I had not tried that. When I did, however, it still wouldn't work... but at least this time it gave me a message that said "ssh: connect to host 192.168.1.104 port 12: Connection refused" ha.

    Well.... Any other suggestions? I think I'm gonna download "cyberduck" and see if I have better luck with that. I know there are some other SSH clients out there too... I'll just test the ones I can.

    Thanks Again! but if you (or anyone) as any other suggestions, please let me know.
     
  6. Gee
    macrumors 65816

    Joined:
    Feb 27, 2004
    Location:
    London, UK
    #6
    You're meant to be on port 22 though? Says port 12 up there.

    Anyways, I connected very easily via FTP using Fetch. Allows you to put things on the appleTV etc.
     
  7. macrumors member

    Joined:
    Jan 3, 2009
    Location:
    Illinois
    #7
    tried both

    I've tried both port 12 and 22.. it was working as port 12 before, i just CANNOT force ssh1... which i REALLY need to do, and non of these other ssh clients are working. crap

    I even partitioned my HD on my macbook to install tiger back onto it. Which turned out to be futile. Could this because i used the ATVUSB creator?
    ?
     
  8. Gee
    macrumors 65816

    Joined:
    Feb 27, 2004
    Location:
    London, UK
    #8
    Was the patchstick process successful? If so, did you try Fetch like I suggested? It's free.
     
  9. macrumors member

    Joined:
    Jan 3, 2009
    Location:
    Illinois
    #9
    sorry, forgot to mention that. yeah, i tried fetch. It just kept saying "connecting", with no end in sight. on that note, I couldn't see any way to use SSH, i'm not really familiar with any of this.. so sorry for that.

    I haven't tried it with tiger though, i should give that a shot.

    first off though- am i configuring it correctly? (i added a screenshot)

    and yes, the patch-stick was successful, and yes, boxee rules.
     

    Attached Files:

  10. Gee
    macrumors 65816

    Joined:
    Feb 27, 2004
    Location:
    London, UK
    #10
    Change FTP to SFTP...
     
  11. macrumors member

    Joined:
    Jan 3, 2009
    Location:
    Illinois
    #11
    i appreciate your help, and your tolerance with my stupidity.

    Now i'm connected, but i still can't write anything (i can't put the .component files in the //system/library/quicktime folder on the ATV)
    :confused:

    Am i trying to put them in a place where is shouldn't be trying to put them? I'm assuming I don't have access because i'm logged in as frontrow, and i don't have permissions anywhere else... but that's where i need permissions, right?
     
  12. Gee
    macrumors 65816

    Joined:
    Feb 27, 2004
    Location:
    London, UK
    #12
    Why? At what point are you failing?
     
  13. macrumors member

    Joined:
    Jan 3, 2009
    Location:
    Illinois
    #13
    I'm assuming its because it's not a file in the branch of file system that I've logged in.

    It fails as soon as i try to write something in the system folder, i get a message that says I do not have the permissions.

    The only thing i can think of is that i'm simply trying to put these files in the wrong place, but on the tutorials i read, they say to put the codec files in //system/library/Quicktime. Is this correct?
     
  14. macrumors member

    Joined:
    Apr 11, 2008
    #14
    Have you checked permissions for the directory you're trying to write to?

    Which codecs are you trying to install? Maybe take a look at atvfiles and NitoTV. The smart installer on Nito is an awesome thing.

    I had a perfectly nice patched system that somehow wandered into the 2.3 update, drank the kool aid and updated itself. Needless to say, it wiped out everything - USB, AFP, etc. I never had issues using Fugu on that system, but Cyberduck never worked.

    I pulled out my original patchstick and it wouldn't work, kept failing at the end. I had no 10.4 systems at home, so I gave the atvusb creator a try and it patched the AppleTV, but no matter what I tried in Fugu it would not connect. It also had issues using Terminal with scp, so I reset it again. Hopefully my latest patchstick will get me back in there...fun, fun, fun.
     
  15. macrumors member

    Joined:
    Jan 3, 2009
    Location:
    Illinois
    #15
    most of this crap is just way over my head... but i'm using a 2.1 version of the apple tv, and i'm not exactly sure where this smart installer is. is that just another name for the downloads under the setting on nito? or under launcher? (I haven't found anything thats actually named smart installer) but from what i have been reading in other places, it seems like i should just be able to do a "smart update through the apple tv, and then plug in my external hard drive, and play whatever movies are on there... this proves to not me so cut and dry (for me anyway).
     
  16. macrumors member

    Joined:
    Apr 11, 2008
    #16
    It's not really a question of being over your head, it's more or less the info that is out there is like trying to turn scrambled eggs back into eggs. The awkward TV wiki's and forum are great sources, but they lack a streamlined starter's guide and support.

    Smart Installer is part of NitoTV, you'll need to install NitoTV and then you'll see the Smart Installer in the NitoTV menu on your tv. This link has some info and a link to download NitoTV.
     
  17. macrumors member

    Joined:
    Jan 3, 2009
    Location:
    Illinois
    #17
    ok, quick question- I have my apple tv on 2.1, should I update to 2.3, or is 2.1 more stable with nitoTV and Boxee?

    For my needs, all I want to do is plug in my external HD to my ATV using the USB port on the back, and be able to use all the the codecs on the ATV natively. I make it sound so simple.... will nitoTV be able to do this for me? or do I need something else?
     
  18. macrumors member

    Joined:
    Apr 11, 2008
    #18
    I wouldn't go any higher than 2.1. From what I understand 2.2 is workable, but 2.3 is crazy. I restored mine to 2.0.2 and plan to keep it right there as it works best for me.

    My complete list of notes is unfortunately on my other laptop at work so I'll go off memory.

    1. Create a patchstick using this guide.
    Note, the link for step 6 is dead. The name of the file is 2Z694-5248-45.dmg. I can't recall where I got it from, but you can google it.

    2. After applying the patchstick you should have ssh available in Fugu. Connect to your AppleTV.
    3. Transfer over NitoTV folder to users/frontrow.
    4. In Terminal run the commands in the Install Instructions.
    5. Once installed create a folder on your desktop named Documents.
    6. Place the MacOSXUpdCombo10.4.9Intel.dmg in the Documents folder.
    7. Transfer that folder over using Fugu to the Frontrow directory.
    8. In Terminal run this command while connected to the AppleTV: sudo dd if=/dev/disk0s2 of=/Users/frontrow/Documents/recovery.dmg bs=1m
    9. On your AppleTV go to NitoTV - and find Smart Installer. Run that and all the others. I didn't do Couch Surfer as I don't need it.
    10. Once it's finished unplug your AppleTV, plug in your USB drive and plug the AppleTV back in.

    You should now be able to access your USB drive from the NitoTV - Files menu. Perian, Quicktime, and MPlayer should be able to handle most codecs.

    Hope that helps!
     
  19. macrumors newbie

    Joined:
    Jun 30, 2005
    #19
    My ATV came with 2.3 preinstalled. Where would I go to find 2.1 so I can use atv usb creator without many problems?
     
  20. macrumors newbie

    Joined:
    Feb 18, 2007
    #20
    Fetch Works Great

    I just installed ATV Flash, love it. Easy to connect to Apple TV. Use Fetch. I tried CyberDuck and Fugu with no success. Just create a new connection in Fetch, Connect to AppleTV.local, user name and password "frontrow" - No Quotes.
     

Share This Page