Cannot change back OSX language settings - help!

Discussion in 'macOS' started by thesheep, Mar 27, 2006.

  1. thesheep macrumors regular

    thesheep

    Joined:
    Mar 27, 2006
    #1
    To demonstrate OSX's Chinese language capabilities I moved Chinese to the top of the language list in System Preferences > International. I got this to work fine, and all the menus etc come out in Chinese (I'm a bit of a Chinese scholar you see). Now I want to revert to English (for my normal working life) and when I try to open System Preferences it just crashes and says the application failed to open. It says do I want to try again. I do this and it crashes again. The third time System Preferences does finally open and it seems that I can reinstate English. I get a message saying do I want to use the new settings or keep the original ones. I have tried both these options but OSX is still refusing to change back the language settings. I have tried it many many times, rebooted the powerbook a bunch of times, always the same - seems like I'm stuck with Chinese!!! Help!
     
  2. elisha cuthbert macrumors 6502a

    elisha cuthbert

    Joined:
    Feb 25, 2006
    Location:
    Melbourne
  3. Deepdale macrumors 68000

    Deepdale

    Joined:
    May 4, 2005
    Location:
    New York
    #3
    I am going to go out on a limb here and say the OP was looking for an alternative to pursuing another language.

    Some of the best help here comes from Australia ... calling mad jew! :)
     
  4. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #4
    Umm... Make a new account? That's probably the quickest option.

    Having said that, it shouldn't be behaving like this in the first place. Do you have plenty of free space? Has the machine been acting erratically in other senses?

    There are two files named com.apple.systempreferences.plist and com.apple.systempreferences.XXX.plist where XXX is a large number. I wonder if dragging these to the Desktop and restarting might make System Preferences co-operate. :)
     
  5. thesheep thread starter macrumors regular

    thesheep

    Joined:
    Mar 27, 2006
    #5
    Yes thank you Elisha, I will bear that in mind as an option ;)

    I've got plenty of disk space (just over half).

    I found the file called com.apple.systempreferences.plist and also another one called com.apple.systemuiserver.XXX.plist, which I moved to the Desktop, but this didn't seem to have any effect. I couldn't find one called com.apple.systempreferences.XXX.plist (where XXX is a big number), at least not using Spotlight.

    Making a new account seems to work - ie everything is in English for that account - but it's not really a solution because everything was set up for the other account. If I'm going to do that I guess I may as well reinstall OSX.

    The only other thing of note is that when I changed the language options, I was half way through installing Virtual PC. I mean that Virtual PC virtual client was installed, but I'd not got round to actually installing the second OS. Don't know if this could have messed things up. The only other little problem I'd noticed with OSX is that I have an Iomega network harddisk with a little utility that loads on startup, and the 'registration' bit of this program always seems to give me an error when I start up.

    I'm a long time Windows user so reinstalling the OS when things get bad is pretty familiar to me, but I was kind of hoping not to have to do that anymore... I guess these things are pretty complicated.
     
  6. gekko513 macrumors 603

    gekko513

    Joined:
    Oct 16, 2003
    #6
    When you change the language setting you need to log out and log in again to change the language for Finder.

    Other applications only need to be restarted.

    When you drag English to the top, try to quit (remember to Quit and not just close the window) Safari and start it again. If it starts in English, your language setting should be fine and you can proceed to log out and log in again.

    Judging by the problems you've had so far that might not work, and you need to troubleshoot the problem more. Try to look in the Console utility and see if there are any errors logged that could point you towards a work around. Maybe you could try to change to a third language. Let me suggest Norwegian. ;)

    Edit: Hm, in this case I will actually suggest repairing permissions. The System Preferences crash can be caused by faulty permissions on some of the preferences files.
     
  7. thesheep thread starter macrumors regular

    thesheep

    Joined:
    Mar 27, 2006
    #7
    Hi, I've also tried repairing the disk and repairing premissions. This didn't help. So now I'm getting ready to do a complete clean install of OSX. And it's a pain, I'm just realising that I have to do a lot of work to reinstall all the applications, set up all my fonts, Thunderbird preferences, etc., etc.... Hmm!
     
  8. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #8
    I wasn't trying to change the language back by removing the preferences, but rather to get System Preferences functioning properly again. FWIW, I think you just set your Menu Bar back to its default settings. :cool:

    Now, languages are held in the NSGlobalDomain. To set English back to default, I think you could possibly just open Terminal and type the following:


    Code:
    defaults write NSGlobalDomain AppleLanguages "(en, fr, de, es, it, nl, ja, XXX)".

    Where XXX is any other language you want to appear on the System Preferences list. Place them in whatever order you like, just so long as en is at the start. :)

    If this looks too risky, just run from that new account. It's easier to transfer everything over to a new account than to completely reinstall the system IMO. :)
     

Share This Page