"Cannot Send Mail" the user name or password is incorrect ??

Discussion in 'iPhone' started by unlimitedx, Oct 15, 2011.

  1. macrumors 6502a

    Jun 15, 2010
    I'm unable to send any email on my iphone 4s. i already had this problem on the iphone 4 but it seems to persist despite getting a new phone. i know that my username and password is correct...

    anyone else got this error before?
  2. macrumors regular

    Jul 2, 2011
    .. are you sure your username and password are correct? lol
  3. thread starter macrumors 6502a

    Jun 15, 2010
    yes :( in fact, the mail app is able to fetch my mail, but i am unable to send any..
  4. macrumors newbie

    Jan 7, 2011
    Is this via iCloud? Saw the same error yesterday... had to enter a different address from the SMTP server rather than the default iCloud smtp that it gave me. smtp.me.com rather than smtp-7.mobile.me.com (or something similar) worked in my case.
  5. macrumors 6502

    Sep 9, 2008
    Just because you can receive means nothing because you can specify a different server, username and password for outgoing mail.
  6. asleep, Oct 16, 2011
    Last edited: Oct 16, 2011

    macrumors 68030


    Sep 26, 2007
    Same problem here: receive/no send

    All settings same as with iPhone 4.
  7. macrumors 6502

    Mar 12, 2011
    if it's icloud - I had this issue throughout the beta testing period - it'll go away after a while - not ideal, but nothing you can do about it - try submitting a bug report to apple.
  8. macrumors member


    Oct 13, 2011
    I've been having the same problem with my yahoo business emails.
    now my phone wont even connect to my emails. this is frustrating..
  9. macrumors 68030


    Sep 26, 2007
    Found a fix for mine...

    When going from 4 to 4S, you have to enter 2 passwords:

    Incoming Mail Server is one the first mail account page, the one where you can toggle the account On or Off.

    Scroll down to Outgoing Mail Server .... see the arrow to the right?

    Clicking it brings you to a SMPT page, where you can activate one or more outgoing servers by clicking on, for instance:


    and entering your password again for that account.

    Account will be verified & voila! :D
  10. thread starter macrumors 6502a

    Jun 15, 2010

    It isn't working for me.. :(

    i input host name as smtp.att.yahoo.com
    user name and pass as my email id and pass
    set SSL to on,
    authentication to password
    and server port to 587

    still doesn't work..
  11. macrumors member


    Oct 13, 2011
    My solution was to keep deleting it, and adding it again, it worked after a couple times. and that's what yahoo suggests to do. keep trying
  12. macrumors 68030


    Sep 26, 2007
    Try 465
  13. thread starter macrumors 6502a

    Jun 15, 2010
    Still failed.. i brought my iphone to the genius bar. the genius was not able to help to fix this either.
  14. macrumors newbie

    Aug 3, 2012
    try this

    Ok I think I may have a solution..this is what I tried and it worked.

    go to :settings
    then Mail,Contacts,Calenders
    then to the email account thats unable to send
    then at the bottom ADVANCED
    then near the bottom there should be a S/MIME turn it on

    this is what I did and it worked !


    By the way I was having problems with my hotmail account. I never had a problem with my Gmail
  15. macrumors 6502

    Jun 25, 2012
    I was getting this message with my osu.edu email account (who goes through outlook)...this was happening about 3 times a week and would come and go

    Here's how I fixed it:

    When in your mail settings, for the outgoing server, even though it says username/password is optional, type your username and password in.

    I haven't had an issue since (about 3 weeks)
  16. macrumors newbie

    Sep 8, 2012

    i was able to solve this with iphone 4, iOS 5.1.1 by re-entering my hotmail account password on the following screen:

    "Settings" -->
    "Mail, Contacts, Calendars" -->
    <select affected mail account, e.g. myname@hotmail.com> -->
    select SMTP server (scroll down to "Outgoing Mail Server" section; the SMTP server for hotmail is 'smtp.live.com') -->
    select SMTP server again (under "Primary Server" section at top; this should be marked as 'On') -->
    on this screen, delete whatever is entered under "Password" and re-enter your login password for the account; when you click "Done" at the top of the keyboard, it will show a series of checkmarks next to each field to let you know the outgoing smtp server configuration is correct. -->

    send a test message from your account to another account to verify that all is well.


Share This Page