Cannot send mail... username or PW incorrect... IT IS CORRECT

Discussion in 'iPhone' started by Hephaestus, May 25, 2011.

  1. Hephaestus macrumors 6502

    Apr 4, 2010
    I've had this problem on my iPhone for a couple of days now, thought it was probably a server issue that would be resolved but it doesn't seem to be going away.

    Basically, whenever I try to send mail using the Mail App I get this error message:

    Cannot Send Mail. The user name or password for "SMTP:" is incorrect.

    I've had this phone for 7 months now and this is the first time I'm having this problem. I can receive emails perfectly fine, its just sending them that is giving me this error. I haven't changed my details at all and I know my PW and username are both correct.

    Someone please help. I don't want to restore my whole phone or anything like that if its avoidable.
  2. iFiend macrumors 65816

    Feb 28, 2011
    Hate to state the obvious but have you tried deleting and re-adding your account? Usually solves problems for me...
  3. TheOriginalKi macrumors 6502

    Jan 2, 2011
    Have you tried deleted and readding the account to the iPhone? By the way do you use exchange or pop3?
  4. Hephaestus thread starter macrumors 6502

    Apr 4, 2010
    My host name says so I assume its pop3. I'll try deleting the account and readding it.
  5. Hephaestus thread starter macrumors 6502

    Apr 4, 2010
    Hmm.. I feel a little foolish now, deleting and readding the account sorted the problem :p Thanks for the tip guys. One more thing though, in my mailboxes it is displaying "inbox" and "sent messages". The outbox is no longer there. Any suggestions?
  6. Givmeabrek macrumors 68030


    Apr 20, 2009
    I didn't think hotmail ( sounds like that is what you have) allowed a pop3 connection anymore. Anyway you should be using an Exchange connection to set up your email. That way you can sync all the folders.

    I'm not sure if this is exactly how a address is setup. It might be the same.
  7. iFiend macrumors 65816

    Feb 28, 2011
    Don't feel foolish at all bud :) Now you know!

    I only use exchange accounts, so I am not sure if they work the same, but under my accounts I have an option to choose which folders to push and that is how I am able to see my outbox. I think that before I used push it may have just taken a bit to show the other folders within my email?


    I would highly suggest using exchange. I have 2 gmail accounts and my school email pushed and it works great. And contrary to popular belief my battery life does not suck because of it. I have an iPhone 4 so YMMV
  8. TheOriginalKi macrumors 6502

    Jan 2, 2011
    You should use Exchange as that will give you instant notifications of emails and also your mailbox will be synced with the server so whatever you do on the phone will also be done on the serve.
  9. Interstella5555 macrumors 603


    Jun 30, 2008
    I don't have an "outbox" in my mail, but in my understanding that's for messages that have been sent to send but are delayed somehow, so you may not see the folder until there's actually a message in there.
  10. Hephaestus thread starter macrumors 6502

    Apr 4, 2010
    Thanks for all the responses guys! I'm not really savvy when it comes to Mail on the iPhone, I didn't actually know what exchange was. I'll change it to exchange right away! Thanks again.
  11. kicko macrumors 65816

    Aug 26, 2008
    It also happens to mine once in a while, both hotmail & gmail.

    I was checking the passwords and all that but simply if you power down and then back on it should fix the issue... until it happens again. It has to be a bug in iOS. I have the verizon version if your wondering.
  12. Hephaestus thread starter macrumors 6502

    Apr 4, 2010
    I just changed it to Exchange and its so much better! I can see all the mailboxes now and it knows what has already been opened on the account. Thanks so much I can't believe I didn't have it like this before.
  13. raviqp macrumors newbie


    Mar 6, 2016
    --- Post Merged, Mar 6, 2016 ---
    I had this problem after setting two step verification on. If all of you cannot login due
    password error even your pass word is correct. download this file "wlsetup-all-14.exe"
    (please search for it). Install it. Then delete your Email ( Then go to
    this link

    5e906a34-9d3a-4e5e-bba9-c9dbcf0bdb1d?ui=en-US&rs=en-US&ad=US#BKMK_AddToUnsupported "

    Though this is for outlook 2007, use some logic and configure these settings according to

    your Live mail.
    This will end all your problems

    Pemsiri Ranaweera
  14. C DM macrumors Nehalem

    Oct 17, 2011
    Why would installing and configuring something in Windows would have something to do with someone having some issues sending emails from their iPhone (someone who very well might not have a Windows computer even)?

Share This Page