Canon 8400F scanner problems?

Discussion in 'Mac Accessories' started by kugino, May 11, 2006.

  1. kugino macrumors 65816


    Jul 10, 2003
    my scanner was not powering on...tried different outlets and no go. so i called canon's CS and the guy said he would send me a new power brick. i was not thrilled at that "fix"...wanted them to send me a new scanner. so i receive the power adapter today and...the scanner's working again. seems like the 8400F has had lots of problems with the original power, if you have this scanner and it doesn't work, could be the power adapter.
  2. Artful Dodger macrumors 68020

    Artful Dodger

    May 28, 2004
    In a false sense of reality...My Mind!
    Thanks for the heads up as I have one as well but no troubles as of yet :rolleyes: I use it but not at a heavy rate, or at least that's what I think. Glad to see/read that yours is fixed and working again, it's a great scanner I think for the price range.
  3. kugino thread starter macrumors 65816


    Jul 10, 2003
    hey AD - if you're using the original power adapter it's a 2-piece one with the small plug that fits easily onto a power strip, right? the replacement they sent me is a one piece where the regulator and plug are on the same part, so it takes us two or three spots on a power strip...not too happy about that, but at least my scanner works. if your scanner is still under warranty (i think it's a 1 year warranty) i'd call them up and tell them your scanner isn't working so you can get the power adapter before your warranty is up ;)
  4. mooncaine macrumors regular

    Dec 19, 2004
    Thanks from me, too!

    I'm about to buy one of those, and I'll make a note to check what kind of power adapter I've got. I'm so glad my google search turned up this thread, and so glad you shared your experience with the 8400F with the rest of us.

Share This Page